summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/spass/Manifest1
-rw-r--r--sci-mathematics/spass/spass-3.7.ebuild81
-rw-r--r--sci-mathematics/spass/spass-3.9.ebuild8
3 files changed, 4 insertions, 86 deletions
diff --git a/sci-mathematics/spass/Manifest b/sci-mathematics/spass/Manifest
index 9b2ec303ee41..00c5827991c8 100644
--- a/sci-mathematics/spass/Manifest
+++ b/sci-mathematics/spass/Manifest
@@ -1,2 +1 @@
-DIST spass37.tgz 1340925 BLAKE2B 5b71778702f61a62e1ec6bd6136fb53ab50f746cab9437510a22141702384b425502c321651910f881c908d0d5640a223ae632e2e0c0f9dbd347cd7ee5c435f6 SHA512 5b4efd7b767dfee3f24e7917a6ec58ac240ab33bf601722eabd50af57637d8fdd62de9e34e7cd1cd98b8b7e371c9e2d47c8fa3e07c6e7ce2fa616a76646a4e12
DIST spass39.tgz 554633 BLAKE2B ca2215f205215805eace6abae82ad281bdadd75f2a52cfe3fed43cb15a4955a4e4d2375fc73a546592315540a7596494bc0df4c53996fd9299e901f68a81ddc8 SHA512 d7ea0697426c476f2e03b2f9078b7e060671067a67fad7144bb5887a2dd3f39e19e1888f121fce546b5d6ea9a4dc458d1cbec56b59c93507e7dc2d0afa25a89b
diff --git a/sci-mathematics/spass/spass-3.7.ebuild b/sci-mathematics/spass/spass-3.7.ebuild
deleted file mode 100644
index 6f16128d8a8c..000000000000
--- a/sci-mathematics/spass/spass-3.7.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit versionator
-
-MY_PV=$(delete_all_version_separators "${PV}")
-MY_P="${PN}${MY_PV}"
-
-DESCRIPTION="An Automated Theorem Prover for First-Order Logic with Equality"
-HOMEPAGE="http://www.spass-prover.org/"
-SRC_URI="http://www.spass-prover.org/download/sources/${MY_P}.tgz"
-
-LICENSE="BSD-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples isabelle"
-
-RDEPEND="isabelle? (
- >=sci-mathematics/isabelle-2011.1-r1:=
- )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/SPASS-${PV}"
-
-src_prepare() {
- sed \
- -e "s:-O3:${CFLAGS}:g" \
- -i configure || die
-}
-
-src_install() {
- default
-
- if use examples; then
- insinto /usr/share/${PN}/
- doins -r examples
- fi
-
- if use isabelle; then
- ewarn "All open source versions of spass are broken with Isabelle 2016.1"
- ISABELLE_HOME="$(isabelle getenv ISABELLE_HOME | cut -d'=' -f 2)"
- [[ -n "${ISABELLE_HOME}" ]] || die "ISABELLE_HOME empty"
- dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
- cat <<- EOF >> "${S}/settings"
- SPASS_HOME="${ROOT}usr/bin"
- SPASS_VERSION="${PV}"
- EOF
- insinto "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
- doins "${S}/settings"
- fi
-}
-
-pkg_postinst() {
- if use isabelle; then
- if [ -f "${ROOT}etc/isabelle/components" ]; then
- if egrep "contrib/${PN}-[0-9.]*" "${ROOT}etc/isabelle/components"; then
- sed -e "/contrib\/${PN}-[0-9.]*/d" \
- -i "${ROOT}etc/isabelle/components"
- fi
- cat <<- EOF >> "${ROOT}etc/isabelle/components"
- contrib/${PN}-${PV}
- EOF
- fi
- fi
-}
-
-pkg_postrm() {
- if use isabelle; then
- if [ ! -f "${ROOT}usr/bin/SPASS" ]; then
- if [ -f "${ROOT}etc/isabelle/components" ]; then
- # Note: this sed should only match the version of this ebuild
- # Which is what we want as we do not want to remove the line
- # of a new spass being installed during an upgrade.
- sed -e "/contrib\/${PN}-${PV}/d" \
- -i "${ROOT}etc/isabelle/components"
- fi
- fi
- fi
-}
diff --git a/sci-mathematics/spass/spass-3.9.ebuild b/sci-mathematics/spass/spass-3.9.ebuild
index 8fdbb7ebb633..a32001e22b91 100644
--- a/sci-mathematics/spass/spass-3.9.ebuild
+++ b/sci-mathematics/spass/spass-3.9.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit versionator
+inherit toolchain-funcs
-MY_PV=$(delete_all_version_separators "${PV}")
+MY_PV=$(ver_rs 1- '' "${PV}")
MY_P="${PN}${MY_PV}"
DESCRIPTION="An Automated Theorem Prover for First-Order Logic with Equality"