summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild6
-rw-r--r--sci-chemistry/openbabel/openbabel-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild b/sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild
index 97dfa6e9a236..61a6ad498b66 100644
--- a/sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild
+++ b/sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild
@@ -80,8 +80,12 @@ RDEPEND="
)
"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
prepare_python_bindings() {
diff --git a/sci-chemistry/openbabel/openbabel-9999.ebuild b/sci-chemistry/openbabel/openbabel-9999.ebuild
index 2c73801d2362..956b061aed0f 100644
--- a/sci-chemistry/openbabel/openbabel-9999.ebuild
+++ b/sci-chemistry/openbabel/openbabel-9999.ebuild
@@ -80,8 +80,12 @@ RDEPEND="
)
"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
prepare_python_bindings() {