summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild4
1 files changed, 1 insertions, 3 deletions
diff --git a/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild b/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild
index 20019c3b7f13..5250c3905761 100644
--- a/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild
+++ b/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6..9}} pypy3 )
inherit distutils-r1
@@ -14,8 +14,6 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
python_test() {
"${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
}