summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-gap/gbnp/Manifest1
-rw-r--r--dev-gap/gbnp/gbnp-1.0.5.ebuild28
-rw-r--r--dev-gap/gbnp/metadata.xml32
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-gap/gbnp/Manifest b/dev-gap/gbnp/Manifest
new file mode 100644
index 000000000000..77b0b757a6ed
--- /dev/null
+++ b/dev-gap/gbnp/Manifest
@@ -0,0 +1 @@
+DIST gbnp-1.0.5.tar.gz 830298 BLAKE2B 785dcf648efa1c859aa5f07510366406b4e91c26b5c322b1909c510beb01b4428d2e3acf8a9415b7b2aef11f2861907b20d8f617fc55c799e9a0bb2aad8b7c5d SHA512 98fecfa1daa240dd9627ad6bf3bea1b01052e6f18e92eb1214b3f83314f79a592f1c83b843d81ebefeda0a167f63e1749a354e40d392aa2d82112ceab2ec3df0
diff --git a/dev-gap/gbnp/gbnp-1.0.5.ebuild b/dev-gap/gbnp/gbnp-1.0.5.ebuild
new file mode 100644
index 000000000000..cadc85d94ec6
--- /dev/null
+++ b/dev-gap/gbnp/gbnp-1.0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="Compute Gröbner bases of noncommutative polynomials"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64"
+IUSE="examples "
+
+gap-pkg_enable_tests
+
+src_prepare() {
+ # The GNUmakefile is used to produce the tarball, not to build the
+ # package.
+ rm GNUmakefile || die
+ default
+}
+
+src_install() {
+ gap-pkg_src_install
+ use examples && dodoc -r examples
+}
diff --git a/dev-gap/gbnp/metadata.xml b/dev-gap/gbnp/metadata.xml
new file mode 100644
index 000000000000..bfb19d13e1fa
--- /dev/null
+++ b/dev-gap/gbnp/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The GBNP package provides algorithms for computing Grobner bases of
+ noncommutative polynomials with coefficients from a field
+ implemented in GAP and with respect to the "total degree first then
+ lexicographical" ordering. Further provided are some variations,
+ such as a weighted and truncated version and a tracing facility. The
+ word "algorithm" is to be interpreted loosely here: in general one
+ cannot expect such an algorithm to terminate, as it would imply
+ solvability of the word problem for finitely presented (semi)groups.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/gbnp</remote-id>
+ </upstream>
+</pkgmetadata>