summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.21.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 2dc78bb4bde8..d18db5cde9bc 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-3.21.2.tar.gz 1795148 BLAKE2B 8b47ee2cac3e3e6d991d99a5ff4d8e6a495629b0e9152c9a0fe8521c18b6ea113742c5e19afbd73b2bd6162145ebdd7087d49335540e8f8b4cfa8a6fadb7a096 SHA512 633a3d34bbf9f5ebf60d419f2bd44a0a0b00788a14fc6df9b835eee8880f3e3c47bb94d85c8ef21d64a6c2b9445ce67c28410b6b9bde282375597f616107a93f
+DIST cpuminer-opt-3.21.3.tar.gz 1796472 BLAKE2B cbbe7e4c93daefab6264c6d73b25e292c23edcc86d58ae6e139a5a6e2e6f354576d3264bc16b13449caa3c05422fb69fa742a990ca71dda1baaa76aa66095118 SHA512 c70e823d371158022733fa5354cf8b58f83b2588368d350b5707baab1b23ef8d5174ff5664444818659c44a97e57bf5cc8b991ab2b5307161eeca4acb7950a9b
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.21.3.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.21.3.ebuild
new file mode 100644
index 000000000000..dd862b295bd0
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.21.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:=
+ dev-libs/jansson:=
+ >=net-misc/curl-7.15[ssl]
+ dev-libs/openssl:0=
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}