summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/dhcp_probe/Manifest1
-rw-r--r--net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild50
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/01_dhcp_probe.5.patch47
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/02_dhcp_probe.8.patch35
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/03_implicit_point_conv_bootp.c.patch21
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/04_linux_32_or_64bits.patch33
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/05-cleanup.patch29
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/06-return.patch11
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/07-comment.patch11
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/08-man8.patch20
10 files changed, 0 insertions, 258 deletions
diff --git a/net-analyzer/dhcp_probe/Manifest b/net-analyzer/dhcp_probe/Manifest
index d14483774cf0..5ed1a3a8246e 100644
--- a/net-analyzer/dhcp_probe/Manifest
+++ b/net-analyzer/dhcp_probe/Manifest
@@ -1,2 +1 @@
-DIST dhcp_probe-1.3.0.tar.gz 211613 BLAKE2B cbcc43b292fe537216ef40de9e417c1f700be4ad5f34feacd9475eb31866b68957ce66c5abc47db3b7e5a0dc8751ca6e54200b79ab2f1f8c3f308f6c1c7aef4d SHA512 d643012529ee5149adbc0c1f19f8e579c55201e86de2aec9b3313be9412db4e973162f864d1baaf79fa340b7bd9a7385f0f1406d1b616e801ced3c7bb387c854
DIST dhcp_probe-1.3.1.tar.gz 246238 BLAKE2B 86c079c4c7951f3a70ced20dbea5d4f0d716335d2f9a18b1b9986965ca0446b5a7b673c7e652405deceeef336218016418a86be1a76d452c7802061403a66e82 SHA512 1002683e6ceb3806289fa9e4879be3d957a9ddc42656d7114942708560f8efba0db058137e04cad092e5a083900987aa1f76c5a7c20db4b57c104dd6a6fcabb6
diff --git a/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild b/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild
deleted file mode 100644
index 3819fc35ca70..000000000000
--- a/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit flag-o-matic
-
-DESCRIPTION="discover DHCP and BootP servers on a directly-attached Ethernet network"
-HOMEPAGE="https://www.net.princeton.edu/software/dhcp_probe/"
-SRC_URI="https://www.net.princeton.edu/software/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- net-libs/libpcap
- >=net-libs/libnet-1.1.2.1-r2
-"
-RDEPEND="${DEPEND}"
-DOCS=(
- "${FILESDIR}"/${PN}_mail
- AUTHORS
- ChangeLog
- NEWS
- README
- TODO
- extras/dhcp_probe.cf.sample
-)
-PATCHES=(
- "${FILESDIR}"/${PV}/01_dhcp_probe.5.patch
- "${FILESDIR}"/${PV}/02_dhcp_probe.8.patch
- "${FILESDIR}"/${PV}/03_implicit_point_conv_bootp.c.patch
- "${FILESDIR}"/${PV}/04_linux_32_or_64bits.patch
- "${FILESDIR}"/${PV}/05-cleanup.patch
- "${FILESDIR}"/${PV}/06-return.patch
- "${FILESDIR}"/${PV}/07-comment.patch
- "${FILESDIR}"/${PV}/08-man8.patch
-)
-
-src_configure() {
- use amd64 && append-flags -D__ARCH__=64
- STRIP=true econf
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}/${PN}.initd" ${PN}
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
-}
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/01_dhcp_probe.5.patch b/net-analyzer/dhcp_probe/files/1.3.0/01_dhcp_probe.5.patch
deleted file mode 100644
index 2d5599c06224..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/01_dhcp_probe.5.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 01_dhcp_probe.5.dpatch by Laurent Guignard <lguignard.debian@gmail.com>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Change a syntax problem in groff file for hyphenation problem
-## Note:
-## Submitted to upstream programmer Irwin Tillman<irwin@princeton.edu>.
-## This patch will be applied in the next version of the upstream code.
-
-
-@DPATCH@
-diff -urNad trunk~/doc/dhcp_probe.cf.5 trunk/doc/dhcp_probe.cf.5
---- trunk~/doc/dhcp_probe.cf.5 2009-03-30 14:53:40.000000000 +0200
-+++ trunk/doc/dhcp_probe.cf.5 2009-03-30 14:57:05.000000000 +0200
-@@ -472,10 +472,10 @@
- .PP
- .RS
- .nf
---p the name of the calling program (e.g. dhcp_probe),
---I the name of the interface on which the unexpected response packet was received
---i the IP source address of the packet
---m Ethernet source address of the packet
-+\-p the name of the calling program (e.g. dhcp_probe),
-+\-I the name of the interface on which the unexpected response packet was received
-+\-i the IP source address of the packet
-+\-m Ethernet source address of the packet
- .fi
- .RE
- .PP
-@@ -483,7 +483,7 @@
- .PP
- .RS
- .nf
---y the non-zero yiaddr value from the packet, when it falls inside a "Lease Network of Concern"
-+\-y the non-zero yiaddr value from the packet, when it falls inside a "Lease Network of Concern"
- .fi
- .RE
- .PP
-@@ -723,7 +723,7 @@
- # alert_program_name2 /absolute/path/name
- #
- # The program specified via 'alert_program_name2' will be called as follows:
--# /absolute/path/name -p name_of_calling_program -I name_of_interface_on_which_the_response_was_received -i IP_source_of_the_response -m ether_src_of_the_response [-y yiaddr_when_in_lease_networks_of_concern]
-+# /absolute/path/name \-p name_of_calling_program \-I name_of_interface_on_which_the_response_was_received \-i IP_source_of_the_response \-m ether_src_of_the_response [\-y yiaddr_when_in_lease_networks_of_concern]
- # The options may appear in any order.
- # The program must silently ignore any options or arguments it does not recognize,
- # so as to be forward-compatible with future enhancements to dhcp_probe.
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/02_dhcp_probe.8.patch b/net-analyzer/dhcp_probe/files/1.3.0/02_dhcp_probe.8.patch
deleted file mode 100644
index d9d3d5aa898a..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/02_dhcp_probe.8.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 02_dhcp_probe.8.dpatch by Laurent Guignard <lguignard.debian@gmail.com>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Change a syntax problem in groff file for hyphenation problem
-## Note:
-## Submitted to upstream programmer Irwin Tillman<irwin@princeton.edu>.
-## This patch will be applied in the next version of the upstream code.
-
-
-@DPATCH@
-diff -urNad trunk~/doc/dhcp_probe.8 trunk/doc/dhcp_probe.8
---- trunk~/doc/dhcp_probe.8 2009-03-30 14:53:40.000000000 +0200
-+++ trunk/doc/dhcp_probe.8 2009-03-30 15:18:09.000000000 +0200
-@@ -380,15 +380,15 @@
- file,
- that program is executed, with the following required options:
- .nf
-- -p the name of the calling program (e.g. dhcp_probe)
-- -I the name of the interface on which the unexpected response packet was received
-- -i the IP source address of the packet
-- -m and the Ethernet source address of the packet
-+ \-p the name of the calling program (e.g. dhcp_probe)
-+ \-I the name of the interface on which the unexpected response packet was received
-+ \-i the IP source address of the packet
-+ \-m and the Ethernet source address of the packet
- .fi
- If the response packet's yiaddr is non-zero and falls within a "Lease Networks of Concern",
- the following optional options are also passed:
- .nf
-- -y the non-zero yiaddr value
-+ \-y the non-zero yiaddr value
- .fi
- (We do not wait for the
- .I alert_program_name2
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/03_implicit_point_conv_bootp.c.patch b/net-analyzer/dhcp_probe/files/1.3.0/03_implicit_point_conv_bootp.c.patch
deleted file mode 100644
index 41af750416bf..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/03_implicit_point_conv_bootp.c.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 03_implicit_point_conv_bootp.c.dpatch by Laurent Guignard <lguignard.debian@gmail.com>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Fix implicit Pointer Converstion in bootp.c file.
-## Fix bug #529635 discovered by Dann Frazier <dannf@debian.org>
-##
-
-@DPATCH@
-diff -urNad trunk~/src/bootp.c trunk/src/bootp.c
---- trunk~/src/bootp.c 2009-03-31 14:19:06.000000000 +0200
-+++ trunk/src/bootp.c 2009-05-21 09:51:26.000000000 +0200
-@@ -11,7 +11,7 @@
- #include "bootp.h"
- #include "configfile.h"
- #include "report.h"
--
-+#include "utils.h"
-
-
-
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/04_linux_32_or_64bits.patch b/net-analyzer/dhcp_probe/files/1.3.0/04_linux_32_or_64bits.patch
deleted file mode 100644
index dcd79ffc58b2..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/04_linux_32_or_64bits.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 04_linux_32_or_64bits.dpatch by Laurent Guignard <lguignard.debian@gmail.com>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: A solution to solve the bug #535361
-## May be this will be a solution with the right method ???
-
-@DPATCH@
-diff -urNad trunk~/src/get_myipaddr.c trunk/src/get_myipaddr.c
---- trunk~/src/get_myipaddr.c 2009-09-03 13:10:32.000000000 +0200
-+++ trunk/src/get_myipaddr.c 2009-09-03 13:15:39.671451172 +0200
-@@ -118,7 +118,21 @@
- #endif /* not STRUCT_SOCKADDR_HAS_SA_LEN */
-
- /* increment ptr to next interface for next time through the loop */
-+#ifdef __ARCH__ /* Debian GNU/Linux behavior for packaging goal */
-+ switch(__ARCH__) {
-+ case 32: /* 32 bits architectures */
-+ ptr += sizeof(ifr->ifr_name) + len;
-+ break;
-+ case 64: /* 64 bits architectures */
-+ ptr += sizeof(struct ifreq);
-+ break;
-+ default: /* Default dhcp_probe behavior */
-+ ptr += sizeof(ifr->ifr_name) + len;
-+ break;
-+ }
-+#else /* Default dhcp_probe behavior */
- ptr += sizeof(ifr->ifr_name) + len;
-+#endif
-
- if (strcmp(ifname, ifr->ifr_name) != 0 ) /* is this the interface we're looking for? */
- continue;
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/05-cleanup.patch b/net-analyzer/dhcp_probe/files/1.3.0/05-cleanup.patch
deleted file mode 100644
index 4151b461bbfd..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/05-cleanup.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- dhcp_probe-1.3.0/src/dhcp_probe.c.orig 2009-03-09 21:17:47.000000000 +0100
-+++ dhcp_probe-1.3.0/src/dhcp_probe.c 2009-11-19 18:09:26.000000000 +0100
-@@ -84,7 +84,6 @@
- struct sigaction sa;
- FILE *pid_fp;
- char *cwd = CWD;
-- int i;
-
- int write_packet_len;
- int bytes_written;
-@@ -98,9 +97,6 @@
- int linktype;
- char pcap_errbuf[PCAP_ERRBUF_SIZE], pcap_errbuf2[PCAP_ERRBUF_SIZE];
-
-- /* for libnet */
-- char libnet_errbuf[LIBNET_ERRBUF_SIZE];
--
- /* get progname = last component of argv[0] */
- prog = strrchr(argv[0], '/');
- if (prog)
-@@ -987,8 +983,6 @@
- Must not be called until after initial configuration is complete.
- */
-
-- int i;
--
- if (! read_configfile(config_file)) {
- my_exit(1, 1, 1);
- }
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/06-return.patch b/net-analyzer/dhcp_probe/files/1.3.0/06-return.patch
deleted file mode 100644
index c27ad646e6c9..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/06-return.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- dhcp_probe-1.3.0/src/dhcp_probe.c.orig 2009-11-19 18:13:31.000000000 +0100
-+++ dhcp_probe-1.3.0/src/dhcp_probe.c 2009-11-19 18:13:59.000000000 +0100
-@@ -684,6 +684,8 @@
- pcap_close(pd_template);
-
- my_exit(0, 1, 1);
-+
-+ return 0; /* will not be reached */
- }
-
-
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/07-comment.patch b/net-analyzer/dhcp_probe/files/1.3.0/07-comment.patch
deleted file mode 100644
index c8184144a597..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/07-comment.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- dhcp_probe-1.3.0/src/configfile.c.orig 2009-03-09 21:17:47.000000000 +0100
-+++ dhcp_probe-1.3.0/src/configfile.c 2009-11-19 18:17:03.000000000 +0100
-@@ -55,7 +55,7 @@
-
- /* parallel arrays of "lease networks of concern" (address & mask), and number of elems in arrays.
- We also precompute a parallel array of 'addr & mask' to save computing these repeatedly later.
--/* If a response already identified as being from a rogue DHCP server contains a yiaddr field field
-+ If a response already identified as being from a rogue DHCP server contains a yiaddr field field
- that falls into one of these networks, it is reported as a matter of special concern.
- */
- struct in_addr lease_networks_of_concern_addr[MAX_LEASE_NETWORKS_OF_CONCERN];
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/08-man8.patch b/net-analyzer/dhcp_probe/files/1.3.0/08-man8.patch
deleted file mode 100644
index 56f8686eaebd..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/08-man8.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- dhcp_probe-1.3.0/doc/dhcp_probe.8.orig 2009-11-19 18:27:47.000000000 +0100
-+++ dhcp_probe-1.3.0/doc/dhcp_probe.8 2009-11-19 18:28:50.000000000 +0100
-@@ -141,7 +141,7 @@
- libraries.
- .SH OPTIONS
- .TP
--.IB \-c \ config_file
-+.BI \-c \ config_file
- Specifies the configuration file.
- If not specified, this defaults to
- .BR /etc/dhcp_probe.cf .
-@@ -253,7 +253,7 @@
- .B \-v
- Display the program's version number, then exit.
- .TP
--.IB \-w \ cwd
-+.BI \-w \ cwd
- Specifies the working directory; shortly after starting the
- program changes its current working directory to this.
- If not specified, this defaults to