summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/hteditor/hteditor-2.1.0-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-editors/hteditor/hteditor-2.1.0-r1.ebuild b/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
index 16a7ab4322f0..5b912857bc6f 100644
--- a/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
+++ b/app-editors/hteditor/hteditor-2.1.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
MY_P=${P/editor}
@@ -39,6 +39,12 @@ PATCHES=(
src_prepare() {
default
eautoreconf
+
+ # Many literals are concatenated with macro definitions.
+ # Instead of patching them all let's pick old c++ standard
+ # and port to c++11 upstream.
+ # https://bugs.gentoo.org/729252
+ append-cxxflags -std=c++98
}
src_configure() {