summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jupyter_packaging/Manifest1
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.11.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jupyter_packaging/Manifest b/dev-python/jupyter_packaging/Manifest
index b58e25485975..491a48ecb119 100644
--- a/dev-python/jupyter_packaging/Manifest
+++ b/dev-python/jupyter_packaging/Manifest
@@ -1 +1,2 @@
DIST jupyter_packaging-0.11.0.tar.gz 21847 BLAKE2B 61e637a0c47b117d42441343bf562f92d665abe0f5111588c91ef65b54e04d5c2878f13b9221128abf7e44070678cb878279a7227511c232d42161a159fd7f21 SHA512 35a5682ef99848f6f22b3cd2abeceaff81d575618ff670bcc664ca0bb77857b38c456a23c03787e9ca23a27901e5456c8417722163385da23efc9b85c15e015a
+DIST jupyter_packaging-0.11.1.tar.gz 21715 BLAKE2B 68cde8becbe10710bc68912da43877db2704f59bbde5247bc2f27553b90cce47f16665326650e3cc2d1de8008d82ff22b8d485b0d2c782ecbb732e7bd059038c SHA512 1027e909222f9dbe9d317030fa07d7a71a91ef9de961681e6842e486e5e12cda03f998e0a7c2c0fc52e9c3ec3f527bf9643bc1640fa94b16b20b500fc69eff42
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.11.1.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.11.1.ebuild
new file mode 100644
index 000000000000..6440233f72bb
--- /dev/null
+++ b/dev-python/jupyter_packaging/jupyter_packaging-0.11.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Tools to help build and install Jupyter Python packages"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/deprecation[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # TODO: package "build"
+ tests/test_build_api.py::test_build_package
+ tests/test_build_api.py::test_deprecated_metadata
+
+ # broken by Gentoo pip patch
+ # TODO: retry when we finally make the patch less intrusive
+ tests/test_datafiles_install.py
+ tests/test_install.py
+ )
+
+ distutils_install_for_testing --via-venv
+ epytest ${deselect[@]/#/--deselect }
+}