summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyrsistent/Manifest1
-rw-r--r--dev-python/pyrsistent/pyrsistent-0.18.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pyrsistent/Manifest b/dev-python/pyrsistent/Manifest
index 592f507f629e..dc72eb3fee46 100644
--- a/dev-python/pyrsistent/Manifest
+++ b/dev-python/pyrsistent/Manifest
@@ -1 +1,2 @@
DIST pyrsistent-0.17.3.tar.gz 106911 BLAKE2B 90a05617ad1e32801286d3da834bf52b4ea864e7463a0789904e4a3bbfda2f7b987e13ea93e16980f2cf3b5d999e6040b7c5980a81b516999175b4e5f2ed392e SHA512 2d18e1d4cfe9a0a576fd363f466ba920094af0b1cbbb49aec11b32df6c23e59f6552235a496838dab00928cc7f6dad2a4a8aaa0b52cb6a38eba6faedd12846c8
+DIST pyrsistent-0.18.0.tar.gz 104215 BLAKE2B 028c26a6b4bcaa8c3e3e1ad1748a6b45f664355c66f0f97c70e4d26c66946a55b346d0340c2e697e9890039692580c03032055cab7c198c39530e5561be83801 SHA512 f56062430f914a884a9317ecf5278ccc09d98f1d6867716f89173db47996b8d4c1ef4f5c0121c955d81fc4fe8aba7d30f38679baea6208168c3952846064cfeb
diff --git a/dev-python/pyrsistent/pyrsistent-0.18.0.ebuild b/dev-python/pyrsistent/pyrsistent-0.18.0.ebuild
new file mode 100644
index 000000000000..2fdd1872803e
--- /dev/null
+++ b/dev-python/pyrsistent/pyrsistent-0.18.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent/Functional/Immutable data structures"
+HOMEPAGE="https://github.com/tobgu/pyrsistent/ https://pypi.org/project/pyrsistent/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest