summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-cblas')
-rw-r--r--app-eselect/eselect-cblas/eselect-cblas-0.1.ebuild24
-rw-r--r--app-eselect/eselect-cblas/files/cblas.eselect-0.115
-rw-r--r--app-eselect/eselect-cblas/files/cblas.eselect.567
-rw-r--r--app-eselect/eselect-cblas/metadata.xml5
4 files changed, 111 insertions, 0 deletions
diff --git a/app-eselect/eselect-cblas/eselect-cblas-0.1.ebuild b/app-eselect/eselect-cblas/eselect-cblas-0.1.ebuild
new file mode 100644
index 000000000000..9b6fe63ed042
--- /dev/null
+++ b/app-eselect/eselect-cblas/eselect-cblas-0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="C-language BLAS module for eselect"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+# Need skel.bash lib
+RDEPEND=">=app-admin/eselect-1.0.5"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="cblas"
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}"/${MODULE}.eselect-${PVR} ${MODULE}.eselect
+ doman "${FILESDIR}"/cblas.eselect.5
+}
diff --git a/app-eselect/eselect-cblas/files/cblas.eselect-0.1 b/app-eselect/eselect-cblas/files/cblas.eselect-0.1
new file mode 100644
index 000000000000..b1bcde4d8d21
--- /dev/null
+++ b/app-eselect/eselect-cblas/files/cblas.eselect-0.1
@@ -0,0 +1,15 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit skel
+
+MODULE="CBLAS"
+IFACE="cblas"
+
+DESCRIPTION="Manage installed $MODULE implementations"
+MAINTAINER="spyderous@gentoo.org"
+SVN_DATE='$Date: 2015/03/31 16:47:06 $'
+VERSION=$(svn_date_to_version "${SVN_DATE}" )
+
+# vim: set ft=eselect :
diff --git a/app-eselect/eselect-cblas/files/cblas.eselect.5 b/app-eselect/eselect-cblas/files/cblas.eselect.5
new file mode 100644
index 000000000000..c27f1f18b3bf
--- /dev/null
+++ b/app-eselect/eselect-cblas/files/cblas.eselect.5
@@ -0,0 +1,67 @@
+.TH "ESELECT" "5" "June 2006" "Gentoo Linux" "eselect"
+.SH "NAME"
+cblas.eselect \- The CBLAS management module for Gentoo's eselect
+.SH "SYNOPSIS"
+\fBeselect cblas\fR [\fBhelp\fR|\fBusage\fR]
+.br
+\fBeselect cblas\fR \fBlist\fR [\fIoptions\fR]
+.br
+\fBeselect cblas\fR \fBadd\fR
+.br
+\fBeselect cblas\fR \fBset\fR \fIimplementation\fR [\fIoptions\fR]
+.br
+\fBeselect cblas\fR \fBshow\fR [\fIoptions\fR]
+
+.SH "DESCRIPTION"
+\fBeselect\fR is Gentoo's configuration and management tool. It features
+modules that care for the individual administrative tasks.
+.SH "ACTION: LIST"
+\fBeselect cblas list\fR [\fIoptions\fR]
+.br
+Displays an ordered list of installed CBLAS implementations. It distinguishes between versions with different
+Application Binary Interfaces (e.g. x86/AMD64). Furthermore, it also distinguishes
+between interfaces to high-level programming languages. Each line holds
+a number and the implementation's name. An asterisk next to one of the list
+elements denotes an active implementation.
+
+phi / # eselect cblas list
+.br
+Installed CBLAS for libdir \fBlib\fR
+.br
+ [1] atlas *
+ [2] reference
+
+Possible \fIoptions\fR to the \fBlist\fR action are restrictions to
+handle only certain ABI\-specific library directories. For example,
+
+\fBeselect cblas list lib64\fR
+
+lists only CBLAS implementations found in \fB/usr/lib64\fR.
+
+.SH "ACTION: SHOW"
+\fBeselect cblas show\fR [\fIoptions\fR]
+.br
+Shows your system's currently active CBLAS implementations.
+
+phi / # eselect cblas show
+.br
+lib: atlas
+.br
+lib64: reference
+
+The same \fIoptions\fR that apply to the \fBlist\fR action can be used
+with the \fBshow\fR action to restrict it to given ABIs.
+.SH "ACTION: SET"
+\fBeselect cblas set\fR \fIimplementation\fR [\fIoptions\fR]
+.br
+Sets your system's currently active CBLAS implementations to \fIimplementation\fR.
+The same \fIoptions\fR that apply to the \fBlist\fR action can be used
+with the \fBset\fR action to restrict it to given ABIs.
+
+phi / # eselect cblas set atlas
+.SH "AUTHOR"
+Danny van Dyk <kugelfang@gentoo.org>
+.br
+Donnie Berkholz <spyderous@gentoo.org>
+.SH "REVISION"
+$Id$
diff --git a/app-eselect/eselect-cblas/metadata.xml b/app-eselect/eselect-cblas/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/app-eselect/eselect-cblas/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>