summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/imgurbash2')
-rw-r--r--app-misc/imgurbash2/Manifest1
-rw-r--r--app-misc/imgurbash2/imgurbash2-3.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/imgurbash2/Manifest b/app-misc/imgurbash2/Manifest
index edbb66aee0bf..96c6e6fa04ab 100644
--- a/app-misc/imgurbash2/Manifest
+++ b/app-misc/imgurbash2/Manifest
@@ -1 +1,2 @@
DIST imgurbash2-3.1.tar.gz 9257 BLAKE2B d7383a89f96387a5dfa9096ad533f334e9e15ec5de8803a4e2623379d036e7f0810166e017b8d89d228418bb035a5dabd1e6d0e305d539544efb1b5fd4ae8bed SHA512 0ec3b081dcd3da7a558c7895eafadc9c98f6b32c4aecb3ff579392599f785bf0716a80053b743ab32fe4e1a9f7253c9c08acf3d6f1c65d2a4c40d4c7ac222e59
+DIST imgurbash2-3.2.tar.gz 9569 BLAKE2B c34cc0cb8e5ca3b7b7da201dab90c3adbd11544950b61c834b6553262ceb42bdf9aa3b3f16f660da6ad1059015e9ca4c013dae93ba90797ec0c15bdda833150b SHA512 e6737967c20d50659222c7dca7c5fbc590a410db54f41419fe009a9fe8dc569c5b9c74eb6b53203690e9a03b0ec5b943bba45abecb243bf2ebc5377e2022471d
diff --git a/app-misc/imgurbash2/imgurbash2-3.2.ebuild b/app-misc/imgurbash2/imgurbash2-3.2.ebuild
new file mode 100644
index 000000000000..c47b35c320b3
--- /dev/null
+++ b/app-misc/imgurbash2/imgurbash2-3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ram-on/imgurbash2.git"
+else
+ SRC_URI="https://github.com/ram-on/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Bash script that uploads/deletes images to/from imgur"
+HOMEPAGE="https://github.com/ram-on/imgurbash2"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="X wayland"
+
+RDEPEND="
+ net-misc/curl
+ wayland? ( gui-apps/wl-clipboard )
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+"
+
+src_install() {
+ einstalldocs
+ dobin imgurbash2
+}