summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/wcd/wcd-5.2.7.ebuild')
-rw-r--r--app-misc/wcd/wcd-5.2.7.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/app-misc/wcd/wcd-5.2.7.ebuild b/app-misc/wcd/wcd-5.2.7.ebuild
deleted file mode 100644
index e6275be727df..000000000000
--- a/app-misc/wcd/wcd-5.2.7.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit epatch toolchain-funcs
-
-DESCRIPTION="Wherever Change Directory"
-HOMEPAGE="http://waterlan.home.xs4all.nl/#WCD_ANCHOR"
-SRC_URI="http://waterlan.home.xs4all.nl/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
-IUSE="nls unicode"
-
-CDEPEND="
- sys-libs/ncurses[unicode?]
- unicode? ( dev-libs/libunistring )"
-DEPEND="${CDEPEND}
- app-text/ghostscript-gpl
- virtual/pkgconfig
-"
-RDEPEND="${CDEPEND}"
-
-S="${WORKDIR}"/${P}/src
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-5.2.5-gentoo.patch
- tc-export CC PKG_CONFIG
-}
-
-src_compile() {
- local mycompile="LFS=1"
- use nls || mycompile="${mycompile} ENABLE_NLS="
- use unicode && mycompile="${mycompile} UCS=1 UNINORM=1"
- emake \
- ${mycompile}
-}
-
-src_install() {
- local DOCS="../README.txt"
- default
- emake DESTDIR="${D}" DOTWCD=1 install-profile sysconfdir="/etc"
-}