summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pstotext/pstotext-1.9-r4.ebuild')
-rw-r--r--app-text/pstotext/pstotext-1.9-r4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/pstotext/pstotext-1.9-r4.ebuild b/app-text/pstotext/pstotext-1.9-r4.ebuild
new file mode 100644
index 000000000000..5aca5d7b5605
--- /dev/null
+++ b/app-text/pstotext/pstotext-1.9-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Extract ASCII text from a PostScript or PDF file"
+HOMEPAGE="http://www.cs.wisc.edu/~ghost/doc/pstotext.htm"
+SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/contrib/${P}.tar.gz"
+
+LICENSE="PSTT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/ncompress"
+RDEPEND="app-text/ghostscript-gpl"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-quote-chars-fix.patch
+ "${FILESDIR}"/${PV}-flags.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install () {
+ dobin pstotext
+ doman pstotext.1
+}