summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/calibre/calibre-7.19.0.ebuild2
-rw-r--r--app-text/calibre/calibre-7.20.0.ebuild2
-rw-r--r--app-text/calibre/files/0001-PIL-11.0-changes-its-webp-features-output.patch36
3 files changed, 40 insertions, 0 deletions
diff --git a/app-text/calibre/calibre-7.19.0.ebuild b/app-text/calibre/calibre-7.19.0.ebuild
index 7dc060197e38..184ae72b4dc1 100644
--- a/app-text/calibre/calibre-7.19.0.ebuild
+++ b/app-text/calibre/calibre-7.19.0.ebuild
@@ -124,6 +124,8 @@ PATCHES=(
# We don't (yet?) package libjxr and it seems to be dead upstream
# (last commit in 2017)
"${FILESDIR}/${PN}-7.0.0-jxr-test.patch"
+ # fix tests with pillow 11
+ "${FILESDIR}"/0001-PIL-11.0-changes-its-webp-features-output.patch
)
src_prepare() {
diff --git a/app-text/calibre/calibre-7.20.0.ebuild b/app-text/calibre/calibre-7.20.0.ebuild
index de5d2fa83dcf..44412dec9bce 100644
--- a/app-text/calibre/calibre-7.20.0.ebuild
+++ b/app-text/calibre/calibre-7.20.0.ebuild
@@ -125,6 +125,8 @@ PATCHES=(
# We don't (yet?) package libjxr and it seems to be dead upstream
# (last commit in 2017)
"${FILESDIR}/${PN}-7.0.0-jxr-test.patch"
+ # fix tests with pillow 11
+ "${FILESDIR}"/0001-PIL-11.0-changes-its-webp-features-output.patch
)
src_prepare() {
diff --git a/app-text/calibre/files/0001-PIL-11.0-changes-its-webp-features-output.patch b/app-text/calibre/files/0001-PIL-11.0-changes-its-webp-features-output.patch
new file mode 100644
index 000000000000..61d00913dd33
--- /dev/null
+++ b/app-text/calibre/files/0001-PIL-11.0-changes-its-webp-features-output.patch
@@ -0,0 +1,36 @@
+From a961ddbfcb96461fd830ccd6facb81d69cc679d8 Mon Sep 17 00:00:00 2001
+From: Kovid Goyal <kovid@kovidgoyal.net>
+Date: Tue, 29 Oct 2024 06:08:04 +0530
+Subject: [PATCH] PIL 11.0 changes its webp features output
+
+---
+ src/calibre/test_build.py | 8 +++-----
+ 1 file changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/src/calibre/test_build.py b/src/calibre/test_build.py
+index 4e3d740705..91c32eba38 100644
+--- a/src/calibre/test_build.py
++++ b/src/calibre/test_build.py
+@@ -436,16 +436,14 @@ def test_imaging(self):
+ out = StringIO()
+ features.pilinfo(out=out, supported_formats=False)
+ out = out.getvalue()
+- for line in '''\
++ lines = '''\
+ --- PIL CORE support ok
+ --- FREETYPE2 support ok
+ --- WEBP support ok
+- --- WEBP Transparency support ok
+- --- WEBPMUX support ok
+- --- WEBP Animation support ok
+ --- JPEG support ok
+ --- ZLIB (PNG/ZIP) support ok
+- '''.splitlines():
++ '''.splitlines()
++ for line in lines:
+ self.assertIn(line.strip(), out)
+ with Image.open(I('lt.png', allow_user_override=False)) as i:
+ self.assertGreaterEqual(i.size, (20, 20))
+--
+2.45.2
+