summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/dns/dns-1.4.4.ebuild')
-rw-r--r--dev-haskell/dns/dns-1.4.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/dns/dns-1.4.4.ebuild b/dev-haskell/dns/dns-1.4.4.ebuild
new file mode 100644
index 000000000000..8d7e11a867ae
--- /dev/null
+++ b/dev-haskell/dns/dns-1.4.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="DNS library in Haskell"
+HOMEPAGE="http://hackage.haskell.org/package/dns"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # ambiguous modules
+
+RDEPEND="dev-haskell/attoparsec:=[profile?]
+ dev-haskell/binary:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/conduit-1.1:=[profile?]
+ >=dev-haskell/conduit-extra-1.1:=[profile?]
+ >=dev-haskell/iproute-1.2.4:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ dev-haskell/network-uri:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/doctest
+ dev-haskell/hspec
+ dev-haskell/word8 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'network >= 2.3' 'network >= 2.3, network-uri'
+}