summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/filestore/filestore-0.6.0.4.ebuild')
-rw-r--r--dev-haskell/filestore/filestore-0.6.0.4.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-haskell/filestore/filestore-0.6.0.4.ebuild b/dev-haskell/filestore/filestore-0.6.0.4.ebuild
new file mode 100644
index 000000000000..e422483e9e8a
--- /dev/null
+++ b/dev-haskell/filestore/filestore-0.6.0.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interface for versioning file stores"
+HOMEPAGE="http://hackage.haskell.org/package/filestore"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+maxcount"
+
+RESTRICT=test # one darcs test fails
+
+RDEPEND=">=dev-haskell/diff-0.2:=[profile?] <dev-haskell/diff-0.4:=[profile?]
+ >=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/split-0.1:=[profile?] <dev-haskell/split-0.3:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-0.4:=[profile?]
+ >=dev-haskell/xml-1.3:=[profile?] <dev-haskell/xml-1.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3
+ dev-haskell/mtl )
+"
+DEPEND+="
+ test? ( dev-vcs/darcs
+ dev-vcs/git
+ dev-vcs/mercurial
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag maxcount maxcount)
+}
+
+src_test() {
+ export HOME=${T}/
+ git config --global user.email "git@src_test"
+ git config --global user.name "Mr. ${P} The Test"
+
+ haskell-cabal_src_test
+}