summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/httpd-shed')
-rw-r--r--dev-haskell/httpd-shed/Manifest3
-rw-r--r--dev-haskell/httpd-shed/files/httpd-shed-0.4-network.patch21
-rw-r--r--dev-haskell/httpd-shed/httpd-shed-0.4-r1.ebuild28
-rw-r--r--dev-haskell/httpd-shed/httpd-shed-0.4.0.2.ebuild31
-rw-r--r--dev-haskell/httpd-shed/httpd-shed-0.4.0.3.ebuild35
-rw-r--r--dev-haskell/httpd-shed/httpd-shed-0.4.ebuild24
-rw-r--r--dev-haskell/httpd-shed/metadata.xml14
7 files changed, 156 insertions, 0 deletions
diff --git a/dev-haskell/httpd-shed/Manifest b/dev-haskell/httpd-shed/Manifest
new file mode 100644
index 000000000000..9a0c67c18377
--- /dev/null
+++ b/dev-haskell/httpd-shed/Manifest
@@ -0,0 +1,3 @@
+DIST httpd-shed-0.4.0.2.tar.gz 4240 SHA256 43f68fcf61e9880e00b5c5a7f2d8f3b89e5a79a803cddb337e66c29e8aca6770 SHA512 1e4da4e52c4f975cd5d66c24e0fc5703a7118a518f59dca0a3ef66b166f1dbfb85b4a036116f958c3ebd7a582d87fc56aa825a89bddf7aedba00fec10617cef6 WHIRLPOOL 37d672ddf4631df8d29ae26e193b47390dc30b24cbe9c63e799d23f51ff243307e4cbfc4491166df98240879c354cf5970d1595faf2c319cd4bdfc555b3e7801
+DIST httpd-shed-0.4.0.3.tar.gz 4308 SHA256 b0ff87d81e61f788d3920d952e4469d984742ba49c006df086c159886bf09218 SHA512 4fc4da5dd42194890e4201129c7217191cc1c8f82a366b84f42f9129c45fa5cb40211674608c84df420f8d8659fd60908880d14176a36f6aa0f89c01a8c1fa6c WHIRLPOOL 653748463726872a0c05c80792586941bdc94174dd2b0a0a81ef54216af52bdd0cbeb578e8e0c1e43eebbdad53f26fea5e8ca2a583253e74aabea9903f557aa7
+DIST httpd-shed-0.4.tar.gz 4065 SHA256 c03f784742bdc3053c7e867e587ee859a9a3adaa082d36bdb2ea69da1b02069f SHA512 71b3fc8038e5245589aab99b9fa3eeef0ec13cc78bba33d88b8c7569f30b0ba18b645a939771b3d325d3e666b99c3c4428403ae016d14df55ce8dcba2e9d61e9 WHIRLPOOL 418a22fa7ad36d885e932ecf051395014bce9a9165bd6ad64559995284879f6ec20d8085af2a8f05a2b7e8d63871ae4d2d5bd5c2f278da0b45959a5ebfe4be1e
diff --git a/dev-haskell/httpd-shed/files/httpd-shed-0.4-network.patch b/dev-haskell/httpd-shed/files/httpd-shed-0.4-network.patch
new file mode 100644
index 000000000000..ca5a113b7014
--- /dev/null
+++ b/dev-haskell/httpd-shed/files/httpd-shed-0.4-network.patch
@@ -0,0 +1,21 @@
+[1 of 1] Compiling Network.Shed.Httpd ( Network/Shed/Httpd.hs, dist/build/Network/Shed/Httpd.o )
+
+Network/Shed/Httpd.hs:142:24:
+ Ambiguous occurrence `sClose'
+ It could refer to either `N.sClose',
+ imported from `Network' at Network/Shed/Httpd.hs:38:1-14
+ or `Network.Socket.sClose',
+ imported from `Network.Socket' at Network/Shed/Httpd.hs:48:1-21
+diff --git a/Network/Shed/Httpd.hs b/Network/Shed/Httpd.hs
+index 9dbc2a2..f4f7d5e 100644
+--- a/Network/Shed/Httpd.hs
++++ b/Network/Shed/Httpd.hs
+@@ -139,7 +139,7 @@ initServerMain processBody sockAddr callOut = do
+ hClose h
+ _ -> hClose h
+ return ()
+- ) `finally` sClose sock
++ ) `finally` N.sClose sock
+ where
+ loopIO m = do m
+ loopIO m
diff --git a/dev-haskell/httpd-shed/httpd-shed-0.4-r1.ebuild b/dev-haskell/httpd-shed/httpd-shed-0.4-r1.ebuild
new file mode 100644
index 000000000000..56ef3c3a0fac
--- /dev/null
+++ b/dev-haskell/httpd-shed/httpd-shed-0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="A simple web-server with an interact style API"
+HOMEPAGE="http://hackage.haskell.org/package/httpd-shed"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-haskell/network:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+PATCHES=("${FILESDIR}"/${P}-network.patch)
diff --git a/dev-haskell/httpd-shed/httpd-shed-0.4.0.2.ebuild b/dev-haskell/httpd-shed/httpd-shed-0.4.0.2.ebuild
new file mode 100644
index 000000000000..66d8195e0b5e
--- /dev/null
+++ b/dev-haskell/httpd-shed/httpd-shed-0.4.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A simple web-server with an interact style API"
+HOMEPAGE="http://hackage.haskell.org/package/httpd-shed"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE="buildexamples"
+
+RDEPEND=">=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-2.6:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag buildexamples buildexamples)
+}
diff --git a/dev-haskell/httpd-shed/httpd-shed-0.4.0.3.ebuild b/dev-haskell/httpd-shed/httpd-shed-0.4.0.3.ebuild
new file mode 100644
index 000000000000..582cd8826c74
--- /dev/null
+++ b/dev-haskell/httpd-shed/httpd-shed-0.4.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A simple web-server with an interact style API"
+HOMEPAGE="http://hackage.haskell.org/package/httpd-shed"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE="buildexamples +network-uri"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-2.7:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
+ !network-uri? ( >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.5:=[profile?] <dev-haskell/network-uri-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag buildexamples buildexamples) \
+ $(cabal_flag network-uri network-uri)
+}
diff --git a/dev-haskell/httpd-shed/httpd-shed-0.4.ebuild b/dev-haskell/httpd-shed/httpd-shed-0.4.ebuild
new file mode 100644
index 000000000000..2bd8bed835df
--- /dev/null
+++ b/dev-haskell/httpd-shed/httpd-shed-0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A simple web-server with an interact style API"
+HOMEPAGE="http://hackage.haskell.org/package/httpd-shed"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-haskell/network[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
diff --git a/dev-haskell/httpd-shed/metadata.xml b/dev-haskell/httpd-shed/metadata.xml
new file mode 100644
index 000000000000..c112085b2d77
--- /dev/null
+++ b/dev-haskell/httpd-shed/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This web server promotes a Request to IO Response function
+ into a local web server. The user can decide how to interpret
+ the requests, and the library is intended for implementing Ajax APIs.
+ </longdescription>
+ <use>
+ <flag name="buildexamples">Build example executables.</flag>
+ <flag name='network-uri'>Get Network.URI from the network-uri package.</flag>
+ </use>
+</pkgmetadata>