summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/regex-base/regex-base-0.93.2-r1.ebuild')
-rw-r--r--dev-haskell/regex-base/regex-base-0.93.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/regex-base/regex-base-0.93.2-r1.ebuild b/dev-haskell/regex-base/regex-base-0.93.2-r1.ebuild
new file mode 100644
index 000000000000..2fbee0d08279
--- /dev/null
+++ b/dev-haskell/regex-base/regex-base-0.93.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Replaces/Enhances Text.Regex"
+HOMEPAGE="http://sourceforge.net/projects/lazy-regex"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=splitbase \
+ --flag=newbase
+}