summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/test-framework/test-framework-0.5.ebuild')
-rw-r--r--dev-haskell/test-framework/test-framework-0.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-haskell/test-framework/test-framework-0.5.ebuild b/dev-haskell/test-framework/test-framework-0.5.ebuild
new file mode 100644
index 000000000000..9a87ec202316
--- /dev/null
+++ b/dev-haskell/test-framework/test-framework-0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.14
+
+EAPI="4"
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Framework for running and organising tests, with HUnit and QuickCheck support"
+HOMEPAGE="http://batterseapower.github.com/test-framework/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.4.0[profile?]
+ >=dev-haskell/ansi-wl-pprint-0.5.1[profile?]
+ >=dev-haskell/hostname-1.0[profile?]
+ >=dev-haskell/regex-posix-0.72[profile?]
+ >=dev-haskell/xml-1.3.5[profile?]
+ >=dev-lang/ghc-6.10.4"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3"