summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust/rust-1.81.0-r100.ebuild')
-rw-r--r--dev-lang/rust/rust-1.81.0-r100.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-lang/rust/rust-1.81.0-r100.ebuild b/dev-lang/rust/rust-1.81.0-r100.ebuild
index 8af903281b73..fd51c0508930 100644
--- a/dev-lang/rust/rust-1.81.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.81.0-r100.ebuild
@@ -604,7 +604,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -627,7 +627,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -645,9 +644,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"