summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild')
-rw-r--r--dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild b/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
new file mode 100644
index 000000000000..b09621e241c0
--- /dev/null
+++ b/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils multilib
+
+DESCRIPTION="Suffix-sorting library (for BWT)"
+HOMEPAGE="http://code.google.com/p/libdivsufsort/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ # will appreciate saner approach, if there is any
+ sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
+ */CMakeLists.txt || die
+}