summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-Patricia')
-rw-r--r--dev-perl/Net-Patricia/Manifest2
-rw-r--r--dev-perl/Net-Patricia/Net-Patricia-1.210.0-r1.ebuild29
-rw-r--r--dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild29
-rw-r--r--dev-perl/Net-Patricia/metadata.xml11
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-perl/Net-Patricia/Manifest b/dev-perl/Net-Patricia/Manifest
new file mode 100644
index 000000000000..cfe66ef02dfb
--- /dev/null
+++ b/dev-perl/Net-Patricia/Manifest
@@ -0,0 +1,2 @@
+DIST Net-Patricia-1.21.tar.gz 27911 SHA256 b03906e3ad3708c1ebef17935c38fef347dbb430b283a263d4f3f4aefbacff64 SHA512 d25d6e4894df365ddd549db748131f1df00b5d9e880b1deb520461ff00fa1035a7beeaeb3bc9c9df4a193cd5e39ab888884fc1ff468b2faa5c8faf1d59b25ed4 WHIRLPOOL a830f3fc8e985f7d37e15a7acebaba4c62086fb54be96809cd8f2f69f6be2f4acc469923ad0769c024a56cca5cf541c2652b354c778351d1a5e585a88c2250f4
+DIST Net-Patricia-1.22.tar.gz 27780 SHA256 70835a926e1c5a8d0324c72fffee82eeb7ec6c141dee04fd446820b64f71c552 SHA512 d76702d30784f8448dcf3a5269e052bc7bd6f5fe5a16824b6e3ede1d0182deb139522e45e1fb78749a7527ddbc950c213d843e43f45b5b0ed63b5b985b329861 WHIRLPOOL 6a4b446a6911a6fbc3bd7696dd5ab99e2fe178209eca450e48f840f25dfe558f80c8e036364ef0cdae8fd3d18db704f984074f52206050aeeeb5728830492135
diff --git a/dev-perl/Net-Patricia/Net-Patricia-1.210.0-r1.ebuild b/dev-perl/Net-Patricia/Net-Patricia-1.210.0-r1.ebuild
new file mode 100644
index 000000000000..e7316cdaf059
--- /dev/null
+++ b/dev-perl/Net-Patricia/Net-Patricia-1.210.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=GRUBER
+MODULE_VERSION=1.21
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Patricia Trie perl module for fast IP address lookups"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="dev-perl/Net-CIDR-Lite
+ ipv6? (
+ dev-perl/Socket6
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
+
+#SRC_TEST="do"
diff --git a/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild b/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild
new file mode 100644
index 000000000000..639a6a6a8471
--- /dev/null
+++ b/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=GRUBER
+MODULE_VERSION=1.22
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Patricia Trie perl module for fast IP address lookups"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="dev-perl/Net-CIDR-Lite
+ ipv6? (
+ dev-perl/Socket6
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
+
+#SRC_TEST="do"
diff --git a/dev-perl/Net-Patricia/metadata.xml b/dev-perl/Net-Patricia/metadata.xml
new file mode 100644
index 000000000000..0e917f20c2bf
--- /dev/null
+++ b/dev-perl/Net-Patricia/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Net-Patricia</remote-id>
+ <remote-id type="cpan-module">Net::Patricia</remote-id>
+ <remote-id type="cpan-module">Net::Patricia::AF_INET</remote-id>
+ <remote-id type="cpan-module">Net::Patricia::AF_INET6</remote-id>
+ </upstream>
+</pkgmetadata>