summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/easyprocess/easyprocess-0.3-r1.ebuild')
-rw-r--r--dev-python/easyprocess/easyprocess-0.3-r1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/easyprocess/easyprocess-0.3-r1.ebuild b/dev-python/easyprocess/easyprocess-0.3-r1.ebuild
index bef5b8faf0c6..c44accf2bd63 100644
--- a/dev-python/easyprocess/easyprocess-0.3-r1.ebuild
+++ b/dev-python/easyprocess/easyprocess-0.3-r1.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Easy to use Python subprocess interface"
HOMEPAGE="https://github.com/ponty/EasyProcess"
SRC_URI="https://github.com/ponty/EasyProcess/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/EasyProcess-${PV}"
LICENSE="BSD-2"
SLOT="0"
@@ -22,6 +23,4 @@ BDEPEND="test? (
x11-base/xorg-server[xvfb]
)"
-S="${WORKDIR}/EasyProcess-${PV}"
-
distutils_enable_tests pytest