summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nest-asyncio')
-rw-r--r--dev-python/nest-asyncio/Manifest1
-rw-r--r--dev-python/nest-asyncio/metadata.xml12
-rw-r--r--dev-python/nest-asyncio/nest-asyncio-1.5.6.ebuild18
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/nest-asyncio/Manifest b/dev-python/nest-asyncio/Manifest
new file mode 100644
index 000000000000..092e8aa8389f
--- /dev/null
+++ b/dev-python/nest-asyncio/Manifest
@@ -0,0 +1 @@
+DIST nest_asyncio-1.5.6.tar.gz 7444 BLAKE2B 04b5808b3187c1155c440c903f0e1d5593f49204e6ffea2a37dc2b6112a365b94ab80823ce512a4cdf6c0799ef1c18d55fc0a841030a2cb93e0913fdf770f247 SHA512 9672cdd72b2bad7c968fa23c94e8bf8014aabf0aefd79b260503e7fe640cb7649f5c266133a4eb87aedcd99cea644fa51f8cd09d789777aca11eb64e84cf4ca5
diff --git a/dev-python/nest-asyncio/metadata.xml b/dev-python/nest-asyncio/metadata.xml
new file mode 100644
index 000000000000..790b1d0cab64
--- /dev/null
+++ b/dev-python/nest-asyncio/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">nest-asyncio</remote-id>
+ <remote-id type="github">erdewit/nest_asyncio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nest-asyncio/nest-asyncio-1.5.6.ebuild b/dev-python/nest-asyncio/nest-asyncio-1.5.6.ebuild
new file mode 100644
index 000000000000..6738b1866591
--- /dev/null
+++ b/dev-python/nest-asyncio/nest-asyncio-1.5.6.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Patch asyncio to allow nested event loops"
+HOMEPAGE="https://github.com/erdewit/nest_asyncio/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+distutils_enable_tests pytest