summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/wtforms-2.2.1.ebuild17
1 files changed, 3 insertions, 14 deletions
diff --git a/dev-python/wtforms/wtforms-2.2.1.ebuild b/dev-python/wtforms/wtforms-2.2.1.ebuild
index aeb0c540d6e9..e52ad989976d 100644
--- a/dev-python/wtforms/wtforms-2.2.1.ebuild
+++ b/dev-python/wtforms/wtforms-2.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( pypy3 python2_7 python3_{6..9} )
inherit distutils-r1
MY_PN="WTForms"
@@ -22,8 +22,6 @@ RESTRICT="!test? ( test )"
S="${WORKDIR}/${MY_P}"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
test? (
dev-python/Babel[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
@@ -32,6 +30,8 @@ BDEPEND="
)
"
+distutils_enable_sphinx docs
+
python_prepare_all() {
# Extension-tests are written for an older version of Django
# Disable pep8 even when it is installed
@@ -43,17 +43,6 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
python_test() {
"${EPYTHON}" tests/runtests.py -v || die
}
-
-python_install_all() {
- distutils-r1_python_install_all
-}