summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-progressbar/ruby-progressbar-1.4.2.ebuild')
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.4.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.2.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.2.ebuild
new file mode 100644
index 000000000000..28a34bda4a1d
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86 ~x86-fbsd"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
+}