summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgconf/pkgconf-9999.ebuild')
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild30
1 files changed, 18 insertions, 12 deletions
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index aed82b201943..eff8a40f5340 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -1,18 +1,21 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/pkgconf/pkgconf.git"
- inherit autotools git-2 multilib-minimal
+ EGIT_REPO_URI=( {https,git}://github.com/pkgconf/${PN}.git )
+ inherit autotools git-r3
else
- inherit autotools multilib-minimal vcs-snapshot
- SRC_URI="https://github.com/pkgconf/pkgconf/tarball/${P} -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+ SRC_URI="https://github.com/pkgconf/pkgconf/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
+ ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux
+ ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
fi
+inherit multilib-minimal
+
DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
HOMEPAGE="https://github.com/pkgconf/pkgconf"
@@ -33,8 +36,9 @@ MULTILIB_CHOST_TOOLS=(
)
src_prepare() {
- [[ -e configure ]] || eautoreconf
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
if use pkg-config; then
MULTILIB_CHOST_TOOLS+=(
/usr/bin/pkg-config
@@ -49,8 +53,10 @@ multilib_src_configure() {
multilib_src_install() {
default
- use pkg-config \
- && dosym pkgconf /usr/bin/pkg-config \
- || rm "${ED}"/usr/share/aclocal/pkg.m4 \
- || die
+
+ if use pkg-config; then
+ dosym pkgconf /usr/bin/pkg-config
+ else
+ rm "${ED%/}"/usr/share/aclocal/pkg.m4 || die
+ fi
}