summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kontact/kontact-4.4.2017.04.ebuild')
-rw-r--r--kde-apps/kontact/kontact-4.4.2017.04.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/kde-apps/kontact/kontact-4.4.2017.04.ebuild b/kde-apps/kontact/kontact-4.4.2017.04.ebuild
new file mode 100644
index 000000000000..6d3442755cb5
--- /dev/null
+++ b/kde-apps/kontact/kontact-4.4.2017.04.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="Container application to unify PIM applications within one (noakonadi branch)"
+HOMEPAGE="https://launchpad.net/~pali/+archive/ubuntu/kdepim-noakonadi"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep kdepimlibs '' 4.14.10_p20160611)
+ $(add_kdeapps_dep libkdepim)
+"
+RDEPEND="${DEPEND}
+ !>kde-apps/kdepimlibs-4.14.11_pre20160211
+"
+
+KMLOADLIBS="libkdepim"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+# kcontactmanager gone from kdesvn
+#
+# xml targets from kmail/ are being uncommented by kde4-meta.eclass
+KMEXTRACTONLY="
+ kmail/
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+="
+ doc/kontact-admin/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}