summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/csound/files/csound-6.15.0-lame.patch')
-rw-r--r--media-sound/csound/files/csound-6.15.0-lame.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-sound/csound/files/csound-6.15.0-lame.patch b/media-sound/csound/files/csound-6.15.0-lame.patch
new file mode 100644
index 000000000000..800ec4fd0f46
--- /dev/null
+++ b/media-sound/csound/files/csound-6.15.0-lame.patch
@@ -0,0 +1,26 @@
+diff --git a/Opcodes/CMakeLists.txt b/Opcodes/CMakeLists.txt
+index af39138..ec48294 100644
+--- a/Opcodes/CMakeLists.txt
++++ b/Opcodes/CMakeLists.txt
+@@ -41,7 +41,7 @@ check_include_file(wiiuse.h WIIUSE_H)
+ find_library(WIIUSE_LIB wiiuse)
+ check_include_file(p5glove.h P5GLOVE_H)
+ find_library(P5GLOVE_LIB p5glove)
+-check_include_file(lame.h LAME_HEADER)
++check_include_file(lame/lame.h LAME_HEADER)
+ find_library(LAME_LIB mp3lame)
+
+ ## OPCODE LIBS WITH NO EXTERNAL DEPENDENCIES ##
+diff --git a/Opcodes/lame.c b/Opcodes/lame.c
+index a951f47..0c1c3e6 100644
+--- a/Opcodes/lame.c
++++ b/Opcodes/lame.c
+@@ -22,7 +22,7 @@
+ */
+
+ #include "csdl.h"
+-#include "lame.h"
++#include "lame/lame.h"
+
+ typedef struct _mp3out {
+ OPDS h;