summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/simplescreenrecorder/simplescreenrecorder-0.3.8.ebuild')
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-0.3.8.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-0.3.8.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-0.3.8.ebuild
index 22b763bb40ea..af9ce70e97a2 100644
--- a/media-video/simplescreenrecorder/simplescreenrecorder-0.3.8.ebuild
+++ b/media-video/simplescreenrecorder/simplescreenrecorder-0.3.8.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic multilib-minimal
+inherit autotools flag-o-matic multilib-minimal
if [[ ${PV} = 9999 ]]; then
inherit git-r3
@@ -43,7 +43,11 @@ RDEPEND="
jack? ( virtual/jack )
pulseaudio? ( media-sound/pulseaudio )
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+PATCHES=( "${FILESDIR}/${P}-qtbindir.patch" )
pkg_setup() {
if [[ ${ABI} == amd64 ]]; then
@@ -68,6 +72,11 @@ pkg_setup() {
append-flags -fPIC
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
multilib_src_configure() {
local myconf=(
$(multilib_native_use_enable debug assert)