summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild')
-rw-r--r--net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild b/net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild
index 0d4a5800b415..2282bae84962 100644
--- a/net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild
+++ b/net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
+
inherit cmake-utils perl-module linux-info python-single-r1
DESCRIPTION="High-level language bindings for libnetfilter_queue"
@@ -13,12 +15,14 @@ KEYWORDS="~x86 ~amd64"
SLOT="0"
LICENSE="GPL-3"
IUSE="perl python examples"
-REQUIRED_USE="|| ( perl python )"
+REQUIRED_USE="|| ( perl python ) python? ( ${PYTHON_REQUIRED_USE} )"
-DEPEND="python? (
+RDEPEND="
+ python? (
dev-python/dpkt[${PYTHON_USEDEP}]
${PYTHON_DEPS}
- )
+ )"
+DEPEND="${RDEPEND}
perl? ( dev-lang/perl )
net-libs/libnetfilter_queue
dev-lang/swig"