summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gr-iio/gr-iio-9999.ebuild')
-rw-r--r--net-wireless/gr-iio/gr-iio-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/net-wireless/gr-iio/gr-iio-9999.ebuild b/net-wireless/gr-iio/gr-iio-9999.ebuild
index ed62ac0d9684..3ebe5b6600a4 100644
--- a/net-wireless/gr-iio/gr-iio-9999.ebuild
+++ b/net-wireless/gr-iio/gr-iio-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit cmake-utils python-single-r1
@@ -14,7 +14,9 @@ if [ "${PV}" = "9999" ]; then
inherit git-r3
KEYWORDS=""
else
- SRC_URI="https://github.com/analogdevicesinc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ COMMIT="8196f3de5b2fdf384801748166cc4ad86a4a9338"
+ SRC_URI="https://github.com/analogdevicesinc/gr-iio/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3+"
@@ -22,7 +24,7 @@ SLOT="0"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
RDEPEND="${PYTHON_DEPS}
- >=net-wireless/gnuradio-3.7.0:=
+ =net-wireless/gnuradio-3.8*:=
dev-libs/boost:=
net-libs/libiio:=
net-libs/libad9361-iio:="