summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild')
-rw-r--r--perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild
new file mode 100644
index 000000000000..9d2b14fc80bc
--- /dev/null
+++ b/perl-core/Math-BigInt/Math-BigInt-1.999.806.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=1.999806
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Arbitrary size floating point math package"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-Complex-1.390.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+PDEPEND="
+ >=virtual/perl-Math-BigInt-FastCalc-0.270.0
+ >=virtual/perl-bignum-0.220.0
+ >=virtual/perl-Math-BigRat-0.260.200
+"
+# where does this come from?
+
+src_test() {
+ perl_rm_files t/author-*.t t/03podcov.t t/00sig.t t/02pod.t
+ perl-module_src_test
+}