summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/onerng')
-rw-r--r--sys-apps/onerng/onerng-3.6-r4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/onerng/onerng-3.6-r4.ebuild b/sys-apps/onerng/onerng-3.6-r4.ebuild
new file mode 100644
index 000000000000..1a720e2d385d
--- /dev/null
+++ b/sys-apps/onerng/onerng-3.6-r4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-single-r1 udev
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="Software for the Open Hardware Random Number Generator called OneRNG"
+HOMEPAGE="https://www.onerng.info/"
+SRC_URI="https://github.com/OneRNG/onerng.github.io/raw/master/sw/${MY_P}.orig.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="virtual/pkgconfig"
+
+DEPEND="virtual/udev"
+
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ app-crypt/gnupg
+ $(python_gen_cond_dep 'dev-python/python-gnupg[${PYTHON_USEDEP}]')
+ sys-apps/rng-tools
+ sys-process/at
+"
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}