summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/distcc/distcc-3.3.ebuild')
-rw-r--r--sys-devel/distcc/distcc-3.3.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/sys-devel/distcc/distcc-3.3.ebuild b/sys-devel/distcc/distcc-3.3.ebuild
index 2a717b289136..aa78ecf5d2b8 100644
--- a/sys-devel/distcc/distcc-3.3.ebuild
+++ b/sys-devel/distcc/distcc-3.3.ebuild
@@ -75,17 +75,18 @@ src_prepare() {
}
src_configure() {
- local myconf="--disable-Werror"
+ local myconf=(
+ --disable-Werror
+ $(use_with gtk)
+ $(use_with gnome)
+ $(use_with gssapi auth)
+ $(use_with zeroconf avahi)
+ )
# --disable-rfc2553 b0rked, bug #254176
- use ipv6 && myconf="${myconf} --enable-rfc2553"
-
- econf \
- $(use_with gtk) \
- $(use_with gnome) \
- $(use_with gssapi auth) \
- $(use_with zeroconf avahi) \
- ${myconf}
+ use ipv6 && myconf+=(--enable-rfc2553)
+
+ econf "${myconf[@]}"
}
src_install() {