summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/extundelete/extundelete-0.2.4-r1.ebuild2
-rw-r--r--sys-fs/extundelete/files/extundelete-0.2.4-clang.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/sys-fs/extundelete/extundelete-0.2.4-r1.ebuild b/sys-fs/extundelete/extundelete-0.2.4-r1.ebuild
index 03b275ad95d1..8df1fab2c980 100644
--- a/sys-fs/extundelete/extundelete-0.2.4-r1.ebuild
+++ b/sys-fs/extundelete/extundelete-0.2.4-r1.ebuild
@@ -14,4 +14,4 @@ KEYWORDS="amd64 ~arm ~sparc x86"
RDEPEND="sys-fs/e2fsprogs"
DEPEND=${RDEPEND}
-PATCHES=( "${FILESDIR}/${P}-e2fsprogs.patch" )
+PATCHES=( "${FILESDIR}/${P}-e2fsprogs.patch" "${FILESDIR}/${P}-clang.patch" )
diff --git a/sys-fs/extundelete/files/extundelete-0.2.4-clang.patch b/sys-fs/extundelete/files/extundelete-0.2.4-clang.patch
new file mode 100644
index 000000000000..aead9bd910f1
--- /dev/null
+++ b/sys-fs/extundelete/files/extundelete-0.2.4-clang.patch
@@ -0,0 +1,11 @@
+--- a/src/extundelete.cc
++++ b/src/extundelete.cc
+@@ -1268,7 +1268,7 @@
+ *new_ino = 0;
+ priv->ret_ino = new_ino;
+ priv->curr_name = curr_part;
+- struct dir_context ctx = {search_flags, DIRENT_FLAG_INCLUDE_REMOVED,
++ struct dir_context ctx = {static_cast<unsigned int>(search_flags), DIRENT_FLAG_INCLUDE_REMOVED,
+ buf, match_name2, priv, 0};
+ errcode_t code = extundelete_block_iterate3(fs, *inode, BLOCK_FLAG_DATA_ONLY,
+ NULL, match_ino, &ctx);