summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xhkeys/files/xhkeys-2.2.1-linux_headers.patch4
-rw-r--r--x11-misc/xhkeys/xhkeys-2.2.1.ebuild24
2 files changed, 15 insertions, 13 deletions
diff --git a/x11-misc/xhkeys/files/xhkeys-2.2.1-linux_headers.patch b/x11-misc/xhkeys/files/xhkeys-2.2.1-linux_headers.patch
index 9e851ada0658..38901576c26a 100644
--- a/x11-misc/xhkeys/files/xhkeys-2.2.1-linux_headers.patch
+++ b/x11-misc/xhkeys/files/xhkeys-2.2.1-linux_headers.patch
@@ -1,7 +1,7 @@
Fix compilation for >=linux-headers-2.6.35
---- xhkeys-2.2.1/xhkeys_cdaudio.c
-+++ xhkeys-2.2.1/xhkeys_cdaudio.c
+--- a/xhkeys_cdaudio.c
++++ b/xhkeys_cdaudio.c
@@ -16,6 +16,7 @@
#include <string.h>
#include <stdarg.h>
diff --git a/x11-misc/xhkeys/xhkeys-2.2.1.ebuild b/x11-misc/xhkeys/xhkeys-2.2.1.ebuild
index d919bb4ac3c3..46f044283181 100644
--- a/x11-misc/xhkeys/xhkeys-2.2.1.ebuild
+++ b/x11-misc/xhkeys/xhkeys-2.2.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=6
inherit eutils
DESCRIPTION="assign particular actions to any key or key combination"
@@ -11,20 +12,21 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc"
-IUSE=""
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
x11-libs/libXt
- x11-libs/libXext"
-DEPEND="${RDEPEND}
+"
+DEPEND="
+ ${RDEPEND}
x11-proto/xextproto
- x11-proto/xproto"
+ x11-proto/xproto
+"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-linux_headers.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-linux_headers.patch
+)
src_install() {
dobin xhkeys xhkconf || die