summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gartoon/gartoon-0.5-r2.ebuild')
-rw-r--r--x11-themes/gartoon/gartoon-0.5-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-themes/gartoon/gartoon-0.5-r2.ebuild b/x11-themes/gartoon/gartoon-0.5-r2.ebuild
new file mode 100644
index 000000000000..1472de283deb
--- /dev/null
+++ b/x11-themes/gartoon/gartoon-0.5-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="Gartoon SVG icon theme"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+IUSE=""
+KEYWORDS="amd64 ~ppc sparc ~x86"
+SLOT="0"
+
+RESTRICT="binchecks strip"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ mydest="/usr/share/icons/${PN}"
+}
+
+src_prepare() {
+ sed -e "s:\(^pixmap_path\) \(\".*\"$\):\1 \"${mydest}/scalable/stock\":" \
+ -i scalable/stock/iconrc || die "sed failed"
+}
+
+src_install() {
+ insinto ${mydest}
+ doins index.theme scalable/stock/iconrc
+
+ dodoc AUTHORS README scalable/stock/changelog_mula.txt
+
+ for dir in apps devices emblems filesystems mimetypes stock; do
+ cd "${S}"/scalable/${dir}
+ insinto ${mydest}/scalable/${dir}
+ for svg in *svg; do
+ doins ${svg}
+ done
+ done
+
+ dosym gnome-lockscreen.svg ${mydest}/scalable/apps/xfce-system-lock.svg
+ dosym control-center2.svg ${mydest}/scalable/apps/xfce-system-settings.svg
+ dosym gnome-logout.svg ${mydest}/scalable/apps/xfce-system-exit.svg
+ dosym mozilla-firefox.svg ${mydest}/scalable/apps/firefox-icon.svg
+ dosym gnome-globe.svg ${mydest}/scalable/apps/firefox-icon-unbranded.svg
+}