summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-09-21 00:43:42 +0000
committerDaniel Goller <morfic@gentoo.org>2004-09-21 00:43:42 +0000
commit06dc992e934e85c4b899dac99527ae96ca42a678 (patch)
tree4b10ab72e58e28bdf7a7d0cd76cbe32c390ba66c
parentnew ebuild, coldplug, to replace the hotplug init.d startup script (diff)
downloadhistorical-06dc992e934e85c4b899dac99527ae96ca42a678.tar.gz
historical-06dc992e934e85c4b899dac99527ae96ca42a678.tar.bz2
historical-06dc992e934e85c4b899dac99527ae96ca42a678.zip
bump to 3.6.1
-rw-r--r--media-gfx/povray/Manifest3
-rw-r--r--media-gfx/povray/files/digest-povray-3.6.11
-rw-r--r--media-gfx/povray/metadata.xml9
-rw-r--r--media-gfx/povray/povray-3.6.1.ebuild42
4 files changed, 55 insertions, 0 deletions
diff --git a/media-gfx/povray/Manifest b/media-gfx/povray/Manifest
index cf087f7e5087..4cfacfb678cd 100644
--- a/media-gfx/povray/Manifest
+++ b/media-gfx/povray/Manifest
@@ -1,10 +1,13 @@
MD5 eb81ead17e6d263b563613b2ce985af2 povray-3.1g-r5.ebuild 3497
+MD5 441ed571958e6bc8f12745d446117d8f povray-3.6.1.ebuild 1127
MD5 184a8d833d690fd9fd32c9965a641dfa povray-3.50c.ebuild 3898
MD5 188dcd946e27c5a275c257228e2712fa ChangeLog 5518
+MD5 41520b183c08f4628b47fde96a77ddfd metadata.xml 283
MD5 d8e13273e95d019333221aa531a33b9a files/gentoo.patch 1829
MD5 dc1e966ff1abdf0e308be6630c50b4d5 files/prob-opt.sh 2582
MD5 05e59113d8c2485e9c60b679e834dff2 files/gentoo-3.50c.patch 247
MD5 21a61dd7740c2a3bec0cc8b27327fae2 files/digest-povray-3.50c 58
+MD5 c46bc643339b324f376236e2a9df237b files/digest-povray-3.6.1 64
MD5 ba3f731e3c5027c2fb00332ae552e1dd files/README.ICC-PGO 1819
MD5 56a3132643c427eee562370d53961f67 files/digest-povray-3.1g-r5 122
MD5 f0f5dba087c85d72f0f982cfe071c50f files/povray-3.50c-amd64.patch 15585
diff --git a/media-gfx/povray/files/digest-povray-3.6.1 b/media-gfx/povray/files/digest-povray-3.6.1
new file mode 100644
index 000000000000..ea0c793199a3
--- /dev/null
+++ b/media-gfx/povray/files/digest-povray-3.6.1
@@ -0,0 +1 @@
+MD5 b5789bb7eeaed0809c5c82d0efda571d povray-3.6.tar.bz2 8200160
diff --git a/media-gfx/povray/metadata.xml b/media-gfx/povray/metadata.xml
new file mode 100644
index 000000000000..b95bae2b9be3
--- /dev/null
+++ b/media-gfx/povray/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>morfic@gentoo.org</email>
+ <description>Persistence of Vision Ray-Tracer</description>
+</maintainer>
+</pkgmetadata>
diff --git a/media-gfx/povray/povray-3.6.1.ebuild b/media-gfx/povray/povray-3.6.1.ebuild
new file mode 100644
index 000000000000..10fbafffaf7d
--- /dev/null
+++ b/media-gfx/povray/povray-3.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.6.1.ebuild,v 1.1 2004/09/21 00:43:42 morfic Exp $
+
+DESCRIPTION="The Persistence Of Vision Ray Tracer"
+SRC_URI="ftp://ftp.povray.org/pub/povray/Official/Unix/povray-3.6.tar.bz2"
+HOMEPAGE="http://www.povray.org/"
+
+SLOT="0"
+LICENSE="povlegal-3.6"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64"
+IUSE="X svga"
+
+DEPEND="media-libs/libpng
+ media-libs/tiff
+ media-libs/jpeg
+ sys-libs/zlib
+ X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )"
+
+
+src_compile() {
+ local myconf
+
+ use X && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"\
+ CFLAGS="${CFLAGS} -DX_DISPLAY_MISSING"
+ use svga || myconf="${myconf} --without-svga"
+
+ econf COMPILED_BY="${USER} (on `uname -n`)" ${myconf} || die
+
+ # Copy the user configuration into /etc/skel
+ cp Makefile Makefile.orig
+ sed -e "s:^povconfuser = .*:povconfuser = ${D}etc/skel/.povray/3.6/:" Makefile.orig >Makefile
+
+ einfo Building povray
+ emake || die "build failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+}