summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2004-04-28 01:56:57 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2004-04-28 01:56:57 +0000
commit28be9d41555d0702e54d27eca3bbaa477c2b90c1 (patch)
tree25a4c1729095af502f0525f0174960847c7ca9c4
parentarm KEYWORDS (diff)
downloadhistorical-28be9d41555d0702e54d27eca3bbaa477c2b90c1.tar.gz
historical-28be9d41555d0702e54d27eca3bbaa477c2b90c1.tar.bz2
historical-28be9d41555d0702e54d27eca3bbaa477c2b90c1.zip
New version (after 10 years!)
-rw-r--r--media-gfx/gnuplot/ChangeLog7
-rw-r--r--media-gfx/gnuplot/Manifest6
-rw-r--r--media-gfx/gnuplot/files/digest-gnuplot-4.01
-rw-r--r--media-gfx/gnuplot/gnuplot-4.0.ebuild95
4 files changed, 106 insertions, 3 deletions
diff --git a/media-gfx/gnuplot/ChangeLog b/media-gfx/gnuplot/ChangeLog
index 739cd0d2d974..847557ce674d 100644
--- a/media-gfx/gnuplot/ChangeLog
+++ b/media-gfx/gnuplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/gnuplot
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.19 2004/04/27 21:43:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.20 2004/04/28 01:56:57 g2boojum Exp $
+
+*gnuplot-4.0 (27 Apr 2004)
+
+ 27 Apr 2004; Grant Goodyear <g2boojum@gentoo.org> +gnuplot-4.0.ebuild:
+ New version. Thanks to Frank Hellmuth and Tsyganenko.
27 Apr 2004; Aron Griffis <agriffis@gentoo.org> gnuplot-3.8j-r1.ebuild:
Add inherit eutils
diff --git a/media-gfx/gnuplot/Manifest b/media-gfx/gnuplot/Manifest
index 500a0d00f340..7a889dc7ac53 100644
--- a/media-gfx/gnuplot/Manifest
+++ b/media-gfx/gnuplot/Manifest
@@ -1,7 +1,9 @@
-MD5 a3d4a0bf747a260329abdb73bb03a484 ChangeLog 3136
+MD5 5a3ec31be79c93af586ce99f9eaac9c6 gnuplot-4.0.ebuild 2377
MD5 d36d3a29a6a4328e002cd4bd62b1e74b gnuplot-3.8j.ebuild 2028
-MD5 0d0ccbc08efef8b97818204479649574 metadata.xml 220
MD5 f38a51b410daedd92961561c04307b74 gnuplot-3.8j-r1.ebuild 2150
+MD5 3af1a9b93328a2c68f8d598ca6330108 ChangeLog 3295
+MD5 0d0ccbc08efef8b97818204479649574 metadata.xml 220
MD5 4ca2057b57f07811b4da7bd8958d50c2 files/digest-gnuplot-3.8j 67
+MD5 ca4f01c5e5b582017b2ff93ac26d650e files/digest-gnuplot-4.0 66
MD5 4ca2057b57f07811b4da7bd8958d50c2 files/digest-gnuplot-3.8j-r1 67
MD5 d6d201e466142a8e19ab7a86da486dde files/gnuplot-3.8j-amd64.diff 329
diff --git a/media-gfx/gnuplot/files/digest-gnuplot-4.0 b/media-gfx/gnuplot/files/digest-gnuplot-4.0
new file mode 100644
index 000000000000..fe9dcb46f985
--- /dev/null
+++ b/media-gfx/gnuplot/files/digest-gnuplot-4.0
@@ -0,0 +1 @@
+MD5 66258443d9f93cc4f46b147dac33e63a gnuplot-4.0.0.tar.gz 2160918
diff --git a/media-gfx/gnuplot/gnuplot-4.0.ebuild b/media-gfx/gnuplot/gnuplot-4.0.ebuild
new file mode 100644
index 000000000000..dabe32deb8b3
--- /dev/null
+++ b/media-gfx/gnuplot/gnuplot-4.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+MY_P="${P}.0"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Quick and useful plotting program"
+HOMEPAGE="http://www.gnuplot.info/"
+SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
+
+LICENSE="gnuplot"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X svga xemacs pdflib ggi png gd readline plotutils doc"
+
+DEPEND="
+ xemacs? ( app-editors/xemacs )
+ pdflib? ( media-libs/pdflib )
+ ggi? ( media-libs/libggi )
+ png? ( media-libs/libpng )
+ gd? ( >=media-libs/libgd-2 )
+ doc? ( virtual/tetex )
+ X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )
+ readline? ( >=sys-libs/readline-4.2 )
+ plotutils? ( media-libs/plotutils )"
+
+src_compile() {
+ local myconf
+
+ myconf=""
+ #myconf=" --with-lasergnu"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use svga \
+ && myconf="${myconf} --with-linux-vga" \
+ || myconf="${myconf} --without-linux-vga"
+
+ use ggi \
+ && myconf="${myconf} --with-ggi=/usr/lib --with-xmi=/usr/lib" \
+ || myconf="${myconf} --without-ggi"
+
+ use readline \
+ && myconf="${myconf} --with-readline=gnu --enable-history-file" \
+ || myconf="${myconf} --with-readline"
+
+ use plotutils \
+ && myconf="${myconf} --with-plot=/usr/lib" \
+ || myconf="${myconf} --without-plot"
+
+ use png \
+ && myconf="${myconf} --with-png=/usr/lib" \
+ || myconf="${myconf} --without-png"
+
+ use gd \
+ && myconf="${myconf} --with-gd" \
+ || myconf="${myconf} --without-gd"
+
+ use pdflib \
+ && myconf="${myconf} --with-pdf=/usr/lib" \
+ || myconf="${myconf} --without-pdf"
+
+ use !xemacs && myconf="${myconf} --without-lisp-files"
+
+ econf \
+ --datadir=/usr/share/gnuplot \
+ ${myconf} || die
+
+ cd ${S}
+ emake || die
+
+ if [ -n "`use doc`" ] ; then
+ cd docs
+ make pdf || die
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc BUGS ChangeLog Copyright FAQ INSTALL NEWS PATCHLEVEL PGPKEYS PORTING README* TODO VERSION
+ use doc && cp docs/gnuplot.pdf ${D}/usr/share/doc/gnuplot-4.0/
+ use doc && cp -a demo ${D}/usr/share/doc/gnuplot-4.0/demo
+}
+
+pkg_postinst() {
+ if [ "`use svga`" ] ; then
+ einfo "In order to enable ordinary users to use SVGA console graphics"
+ einfo "gnuplot needs to be set up as setuid root. Please note that"
+ einfo "this is usually considered to be a security hazard."
+ einfo "As root, manually chmod u+s /usr/bin/gnuplot"
+ fi
+}