summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Bormolini <lordjoe@gentoo.org>2001-08-03 09:10:31 +0000
committerJoe Bormolini <lordjoe@gentoo.org>2001-08-03 09:10:31 +0000
commit542fe40055443cd1fd2a1325a05947c8403a16fe (patch)
treeee3d5dfe3948879cc18d710f93c0eca918d020e9
parent4 new ebuilds by Craig Joly, read the wiki note before working on them (diff)
downloadhistorical-542fe40055443cd1fd2a1325a05947c8403a16fe.tar.gz
historical-542fe40055443cd1fd2a1325a05947c8403a16fe.tar.bz2
historical-542fe40055443cd1fd2a1325a05947c8403a16fe.zip
A bunch of bbtools ebuilds from Craig Joly <joly@ee.ualberta.ca> and myself Joe Bormolini <lordjoe@gentoo.org>
-rw-r--r--app-admin/bbapm/bbapm-0.0.1.ebuild29
-rw-r--r--app-admin/bbapm/files/digest-bbapm-0.0.11
-rw-r--r--app-admin/bbsload/bbsload-0.2.5.ebuild28
-rw-r--r--app-admin/bbsload/files/digest-bbsload-0.2.51
-rw-r--r--app-misc/bbrun/bbrun-1.1.ebuild32
-rw-r--r--app-misc/bbrun/files/digest-bbrun-1.11
-rw-r--r--app-misc/bbweather/bbweather-0.3.ebuild27
-rw-r--r--app-misc/bbweather/files/digest-bbweather-0.31
-rw-r--r--app-misc/toolbox/files/digest-toolbox-0.6.01
-rw-r--r--app-misc/toolbox/toolbox-0.6.0.ebuild26
-rw-r--r--net-dialup/bbppp/bbppp-0.2.2.ebuild28
-rw-r--r--net-dialup/bbppp/files/digest-bbppp-0.2.21
-rw-r--r--net-mail/bbmail/bbmail-0.6.11.ebuild35
-rw-r--r--net-mail/bbmail/files/bbmail-qmail.patch35
-rw-r--r--net-mail/bbmail/files/digest-bbmail-0.6.111
15 files changed, 247 insertions, 0 deletions
diff --git a/app-admin/bbapm/bbapm-0.0.1.ebuild b/app-admin/bbapm/bbapm-0.0.1.ebuild
new file mode 100644
index 000000000000..05702d5643c7
--- /dev/null
+++ b/app-admin/bbapm/bbapm-0.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Craig Joly <joly@ee.ualberta.ca>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox advanced power management tool"
+SRC_URI="http://bbtools.thelinuxcommunity.org/sources/${A}"
+HOMEPAGE="http://bbtools.thelinuxcommunity.org/contrib.phtml"
+
+DEPEND=">=x11-wm/blackbox-0.61
+ >=sys-apps/apmd-3.0.1"
+
+src_compile() {
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README TODO
+ cd /usr/X11R6/bin/wm
+ cp blackbox blackbox.bak
+ sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbapm \&\n&": blackbox.bak > blackbox
+}
+
diff --git a/app-admin/bbapm/files/digest-bbapm-0.0.1 b/app-admin/bbapm/files/digest-bbapm-0.0.1
new file mode 100644
index 000000000000..33ef2d23d594
--- /dev/null
+++ b/app-admin/bbapm/files/digest-bbapm-0.0.1
@@ -0,0 +1 @@
+MD5 4d2629959bd907696c7765b7c34bc54f bbapm-0.0.1.tar.gz
diff --git a/app-admin/bbsload/bbsload-0.2.5.ebuild b/app-admin/bbsload/bbsload-0.2.5.ebuild
new file mode 100644
index 000000000000..af2cd33709e1
--- /dev/null
+++ b/app-admin/bbsload/bbsload-0.2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@gentoo.org>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox load monitor"
+SRC_URI="http://bbtools.thelinuxcommunity.org/sources/${A}"
+HOMEPAGE="http://bbtools.windsofstorm.net/available.phtml#bbsload"
+
+DEPEND=">=x11-wm/blackbox-0.61"
+
+src_compile() {
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc README COPYING AUTHORS BUGS INSTALL ChangeLog NEWS TODO data/README.bbsload
+ cd /usr/X11R6/bin/wm
+ cp blackbox blackbox.bak
+ sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbsload \&\n&": blackbox.bak > blackbox
+}
+
diff --git a/app-admin/bbsload/files/digest-bbsload-0.2.5 b/app-admin/bbsload/files/digest-bbsload-0.2.5
new file mode 100644
index 000000000000..43177b055ffe
--- /dev/null
+++ b/app-admin/bbsload/files/digest-bbsload-0.2.5
@@ -0,0 +1 @@
+MD5 b7096bddeffbc37d87fa1000370b67e6 bbsload-0.2.5.tar.gz
diff --git a/app-misc/bbrun/bbrun-1.1.ebuild b/app-misc/bbrun/bbrun-1.1.ebuild
new file mode 100644
index 000000000000..b6d0fa6749c3
--- /dev/null
+++ b/app-misc/bbrun/bbrun-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Craig Joly <joly@ee.ualberta.ca>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox program execution dialog box"
+SRC_URI="http://bbtools.thelinuxcommunity.org/sources/contrib/${A}"
+HOMEPAGE="http://bbtools.thelinuxcommunity.org/contrib.phtml"
+
+DEPEND=">=x11-wm/blackbox-0.61
+ >=x11-libs/gtk+-1.2.10"
+
+src_compile() {
+
+ cd ${S}/bbrun
+ cp Makefile Makefile.bak
+ try "sed '/CFLAGS =/ s:$:" -I/usr/X11R6/include/gtk-1.2 -I/usr/include/glib-1.2 ${CFLAGS}":' Makefile.bak > Makefile"
+ try emake
+
+}
+
+src_install () {
+
+ dodoc README COPYING
+ dointo /usr/X11R6/bin
+ dobin bbrun/bbrun
+ cd /usr/X11R6/bin/wm
+ cp blackbox blackbox.bak
+ sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbrun \&\n&": blackbox.bak > blackbox
+}
+
diff --git a/app-misc/bbrun/files/digest-bbrun-1.1 b/app-misc/bbrun/files/digest-bbrun-1.1
new file mode 100644
index 000000000000..318980890c4f
--- /dev/null
+++ b/app-misc/bbrun/files/digest-bbrun-1.1
@@ -0,0 +1 @@
+MD5 19264424d472d4de7336429ce507b206 bbrun-1.1.tar.gz
diff --git a/app-misc/bbweather/bbweather-0.3.ebuild b/app-misc/bbweather/bbweather-0.3.ebuild
new file mode 100644
index 000000000000..604d42e2fc38
--- /dev/null
+++ b/app-misc/bbweather/bbweather-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@gentoo.org>
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox weather monitor"
+SRC_URI="http://www.netmeister.org/apps/${A}"
+HOMEPAGE="http://www.netmeister.org/apps/bbweather/index.html"
+
+DEPEND=">=x11-wm/blackbox-0.61
+ >=net-misc/wget-1.7
+ >=sys-devel/perl-5.6.1"
+
+src_compile() {
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} mandir=${D}/usr/share/man install
+ dodoc README COPYING AUTHORS INSTALL ChangeLog NEWS TODO data/README.bbweather
+}
+
diff --git a/app-misc/bbweather/files/digest-bbweather-0.3 b/app-misc/bbweather/files/digest-bbweather-0.3
new file mode 100644
index 000000000000..31562ff36cc9
--- /dev/null
+++ b/app-misc/bbweather/files/digest-bbweather-0.3
@@ -0,0 +1 @@
+MD5 526e505dc2938016fb0a7622896b5d3d bbweather-0.3.tar.bz2
diff --git a/app-misc/toolbox/files/digest-toolbox-0.6.0 b/app-misc/toolbox/files/digest-toolbox-0.6.0
new file mode 100644
index 000000000000..1f89040a69bb
--- /dev/null
+++ b/app-misc/toolbox/files/digest-toolbox-0.6.0
@@ -0,0 +1 @@
+MD5 72283d94f128bdfd90887eb1489daafb toolbox-0.6.0.tar.gz
diff --git a/app-misc/toolbox/toolbox-0.6.0.ebuild b/app-misc/toolbox/toolbox-0.6.0.ebuild
new file mode 100644
index 000000000000..4208f636c99a
--- /dev/null
+++ b/app-misc/toolbox/toolbox-0.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Craig Joly <joly@ee.ualberta.ca>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox style file configuration utility"
+SRC_URI="http://movingparts.windsofstorm.net/bbkeys/${A}"
+HOMEPAGE="http://movingparts.windsofstorm.net/code.shtml#toolbox"
+
+DEPEND=">=x11-wm/blackbox-0.61
+ >=x11-libs/qt-x11-2.3.0"
+
+src_compile() {
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}
+
diff --git a/net-dialup/bbppp/bbppp-0.2.2.ebuild b/net-dialup/bbppp/bbppp-0.2.2.ebuild
new file mode 100644
index 000000000000..200ab092536b
--- /dev/null
+++ b/net-dialup/bbppp/bbppp-0.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@gentoo.org>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox ppp frontend/monitor"
+SRC_URI="http://bbtools.thelinuxcommunity.org/sources/${A}"
+HOMEPAGE="http://bbtools.windsofstorm.net/available.phtml#bbppp"
+
+DEPEND=">=x11-wm/blackbox-0.61"
+
+src_compile() {
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc README COPYING AUTHORS BUGS INSTALL ChangeLog NEWS TODO data/README.bbppp
+ cd /usr/X11R6/bin/wm
+ cp blackbox blackbox.bak
+ sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbppp \&\n&": blackbox.bak > blackbox
+}
+
diff --git a/net-dialup/bbppp/files/digest-bbppp-0.2.2 b/net-dialup/bbppp/files/digest-bbppp-0.2.2
new file mode 100644
index 000000000000..09f57dd1507b
--- /dev/null
+++ b/net-dialup/bbppp/files/digest-bbppp-0.2.2
@@ -0,0 +1 @@
+MD5 e1e8a4795c5446688144ec25112a5b40 bbppp-0.2.2.tar.gz
diff --git a/net-mail/bbmail/bbmail-0.6.11.ebuild b/net-mail/bbmail/bbmail-0.6.11.ebuild
new file mode 100644
index 000000000000..134913370f08
--- /dev/null
+++ b/net-mail/bbmail/bbmail-0.6.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Craig Joly <joly@ee.ualberta.ca>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox mail notification, patched for maildir"
+SRC_URI="http://bbtools.thelinuxcommunity.org/sources/${A}.tar.gz"
+HOMEPAGE="http://bbtools.thelinuxcommunity.org/available.phtml"
+
+DEPEND=">=x11-wm/blackbox-0.61"
+
+src_unpack () {
+
+ unpack ${P}.tar.gz
+ cd ${S}
+ # This is a patch for bbmail to support qmail style maildirs
+ try patch -p1 < ${FILESDIR}/bbmail-qmail.patch
+}
+
+src_compile() {
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README TODO data/README.bbmail
+ cd /usr/X11R6/bin/wm
+ cp blackbox blackbox.bak
+ sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbmail \&\n&": blackbox.bak > blackbox
+}
diff --git a/net-mail/bbmail/files/bbmail-qmail.patch b/net-mail/bbmail/files/bbmail-qmail.patch
new file mode 100644
index 000000000000..8e23afd63991
--- /dev/null
+++ b/net-mail/bbmail/files/bbmail-qmail.patch
@@ -0,0 +1,35 @@
+--- bbmail-0.6.10.orig/bbmail.cc
++++ bbmail-0.6.10/bbmail.cc
+@@ -55,7 +55,7 @@
+ }
+
+ bool Checkmail::CheckMHBox(int spoolno,bool force) {
+- struct stat file_status;
++ struct stat file_status, maildir_status;
+ FILE *fp;
+ int num[2]={-1,-1};
+ int number_of_values;
+@@ -67,6 +67,23 @@
+ bbtool->getResource()->spoolfile[spoolno].filename);
+ return(false);
+ }
++
++ // check maildir new/ and cur/ directories
++ char *maildir = new
++ char[strlen (bbtool->getResource()->spoolfile[spoolno].filename) + 5];
++ sprintf (maildir, "%s/new", bbtool->getResource()->spoolfile[spoolno].filename);
++ if (stat (maildir, &maildir_status) == 0 &&
++ maildir_status.st_mtime > file_status.st_mtime) {
++ file_status.st_mtime = maildir_status.st_mtime;
++ }
++
++ sprintf (maildir, "%s/cur", bbtool->getResource()->spoolfile[spoolno].filename);
++ if (stat (maildir, &maildir_status) == 0 &&
++ maildir_status.st_mtime > file_status.st_mtime) {
++ file_status.st_mtime = maildir_status.st_mtime;
++ }
++
++ delete [] maildir;
+ }
+
+ if ((file_status.st_mtime != spoolfile[spoolno].last_mtime)&&
diff --git a/net-mail/bbmail/files/digest-bbmail-0.6.11 b/net-mail/bbmail/files/digest-bbmail-0.6.11
new file mode 100644
index 000000000000..98e7288a0d76
--- /dev/null
+++ b/net-mail/bbmail/files/digest-bbmail-0.6.11
@@ -0,0 +1 @@
+MD5 26e442a09ceab67a39b73ad80ceafff9 bbmail-0.6.11.tar.gz