summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-05-20 06:32:24 +0000
committerHans de Graaff <graaff@gentoo.org>2012-05-20 06:32:24 +0000
commitdea1e49bde165429f32e9c343a1415682880e60a (patch)
treee9a89da03c4d8d0a46a396dce16a01616d48d1d2
parentold (diff)
downloadhistorical-dea1e49bde165429f32e9c343a1415682880e60a.tar.gz
historical-dea1e49bde165429f32e9c343a1415682880e60a.tar.bz2
historical-dea1e49bde165429f32e9c343a1415682880e60a.zip
Version bump.
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
-rw-r--r--dev-ruby/racc/ChangeLog7
-rw-r--r--dev-ruby/racc/racc-1.4.8.ebuild84
-rw-r--r--dev-ruby/rake-compiler/ChangeLog7
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.8.1.ebuild61
4 files changed, 157 insertions, 2 deletions
diff --git a/dev-ruby/racc/ChangeLog b/dev-ruby/racc/ChangeLog
index 43ec1385797a..fcd62328460d 100644
--- a/dev-ruby/racc/ChangeLog
+++ b/dev-ruby/racc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/racc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.67 2012/02/05 20:48:55 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.68 2012/05/20 06:29:53 graaff Exp $
+
+*racc-1.4.8 (20 May 2012)
+
+ 20 May 2012; Hans de Graaff <graaff@gentoo.org> +racc-1.4.8.ebuild:
+ Version bump.
05 Feb 2012; Markus Meier <maekke@gentoo.org> racc-1.4.7.ebuild:
add ~arm, bug #332593
diff --git a/dev-ruby/racc/racc-1.4.8.ebuild b/dev-ruby/racc/racc-1.4.8.ebuild
new file mode 100644
index 000000000000..9e61042a41fd
--- /dev/null
+++ b/dev-ruby/racc/racc-1.4.8.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.8.ebuild,v 1.1 2012/05/20 06:29:53 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ree18 ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A LALR(1) parser generator for Ruby"
+HOMEPAGE="http://www.loveruby.net/en/racc.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+ruby_add_bdepend "dev-ruby/rake
+ doc? ( dev-ruby/hoe )"
+
+all_ruby_prepare() {
+ sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
+
+ # Avoid depending on rake-compiler since we don't use it to compile
+ # the extension.
+ sed -i -e '/rake-compiler/ s:^:#:' -e '/extensiontask/ s:^:#:' Rakefile
+ sed -i -e '/ExtensionTask/,/^ end/ s:^:#:' Rakefile
+
+ # Avoid isolation since dependencies are not properly declared.
+ sed -i -e 's/, :isolate//' Rakefile || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ ${RUBY} -Cext/racc extconf.rb || die
+ ;;
+ esac
+}
+
+each_ruby_compile() {
+ case ${RUBY} in
+ *jruby)
+ einfo "Under JRuby, racc cannot use the shared object parser, so instead"
+ einfo "you have to rely on the pure Ruby implementation."
+ ;;
+ *)
+ emake -Cext/racc
+ # Copy over the file here so that we don't have to do
+ # special ruby install for JRuby and the other
+ # implementations.
+ cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ewarn "Using JRuby 1.5.2 the tests are currently badly broken,"
+ ewarn "so they are disabled until a new racc or a new JRuby is"
+ ewarn "released."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r rdoc
+
+ docinto examples
+ dodoc -r sample
+}
diff --git a/dev-ruby/rake-compiler/ChangeLog b/dev-ruby/rake-compiler/ChangeLog
index 6888d55468f9..01d1ccc6f801 100644
--- a/dev-ruby/rake-compiler/ChangeLog
+++ b/dev-ruby/rake-compiler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rake-compiler
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.45 2012/04/23 18:02:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.46 2012/05/20 06:32:24 graaff Exp $
+
+*rake-compiler-0.8.1 (20 May 2012)
+
+ 20 May 2012; Hans de Graaff <graaff@gentoo.org> +rake-compiler-0.8.1.ebuild:
+ Version bump.
23 Apr 2012; Alexis Ballier <aballier@gentoo.org> rake-compiler-0.8.0.ebuild:
keyword ~x86-fbsd
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.8.1.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.8.1.ebuild
new file mode 100644
index 000000000000..f6407bf4b3e3
--- /dev/null
+++ b/dev-ruby/rake-compiler/rake-compiler-0.8.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/rake-compiler-0.8.1.ebuild,v 1.1 2012/05/20 06:32:24 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+# Tests for now seem only to work when rubygems is fully installed for
+# the implementation and that for now only means Ruby 1.8
+RUBY_FAKEGEM_TASK_TEST="-f tasks/rspec.rake -f tasks/cucumber.rake spec cucumber"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
+HOMEPAGE="http://github.com/luislavena/rake-compiler"
+LICENSE="as-is" # truly
+
+SRC_URI="http://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+RUBY_S="luislavena-${PN}-*"
+
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+USE_RUBY="ruby18 ree18" \
+ ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/rubygems )"
+ruby_add_rdepend "dev-ruby/rake"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19|*jruby)
+ # Remove this task so that it won't load on Ruby 1.9 and JRuby
+ # that lack the package_task file. It is, though, needed for the
+ # tests
+ rm tasks/gem.rake || die
+ # Remove specs aimed at a C-compiling ruby implementation.
+ rm spec/lib/rake/extensiontask_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby19)
+ ${RUBY} -S rspec spec || die "Tests failed."
+ ;;
+ *jruby)
+ ${RUBY} -S rspec spec || die "Tests failed."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}