summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-05-13 09:46:17 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-05-13 09:46:17 +0000
commitfaf203450f3b5ae7a4b20fa9c33cc2ae6bac6b0f (patch)
tree3c8a2fed700158f063c63989e274a395f1361e48
parentInitial revision (~x86 masked) Closes #19611. (diff)
downloadhistorical-faf203450f3b5ae7a4b20fa9c33cc2ae6bac6b0f.tar.gz
historical-faf203450f3b5ae7a4b20fa9c33cc2ae6bac6b0f.tar.bz2
historical-faf203450f3b5ae7a4b20fa9c33cc2ae6bac6b0f.zip
Final cleanups from PHP eclass
-rw-r--r--dev-php/mod_php/ChangeLog5
-rw-r--r--dev-php/mod_php/Manifest12
-rw-r--r--dev-php/mod_php/mod_php-4.3.1-r3.ebuild16
3 files changed, 14 insertions, 19 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index 2eaca48fc8b1..e822fcc13e4a 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,8 +1,11 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.62 2003/05/12 16:13:58 heim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.63 2003/05/13 09:46:07 robbat2 Exp $
*mod_php-4.3.1-r3 (23 Apr 2003)
+
+ 13 May 2003; Robin H. Johnson <robbat2@gentoo.org> mod_php-4.3.1-r3.ebuild:
+ More cleanups, nearly ready for ~x86.
24 Apr 2003; Tal Peer <coredumb@gentoo.org> mod_php-4.3.1-r2.ebuild,
mod_php-4.3.1-r3.ebuild:
diff --git a/dev-php/mod_php/Manifest b/dev-php/mod_php/Manifest
index 826452779325..009e089f919a 100644
--- a/dev-php/mod_php/Manifest
+++ b/dev-php/mod_php/Manifest
@@ -1,10 +1,10 @@
-MD5 43b8f24823b71cdbe85c69d2ff366396 mod_php-4.3.1-r3.ebuild 2617
-MD5 40e7c2563c18f1b091ef5fb26c4d59ed mod_php-4.3.1.ebuild 8688
-MD5 a2d7442983bad757852f0265283e5827 mod_php-4.3.1-r2.ebuild 9133
+MD5 991fc6f963ee328e37efb3ae9ba2f9ef mod_php-4.3.1-r3.ebuild 2362
+MD5 8a10662c67b87c1c40d3eedb598280bf mod_php-4.3.1.ebuild 8922
+MD5 c99a00bf82ec9a082399ab1dd931c415 mod_php-4.3.1-r2.ebuild 9241
MD5 6de98d80b82a71ed8845884b0bd5676e mod_php-4.2.3-r2.ebuild 8071
-MD5 d470c7ff3d3a9d470e845eb240519982 mod_php-4.3.0-r2.ebuild 8635
-MD5 c103f3a2317edabcd031404683427056 ChangeLog 14282
-MD5 68f967fbb5cf7faabf563eb9f340da35 mod_php-4.3.1-r1.ebuild 8904
+MD5 dfc6bd16160024127fa9b0c242fc8ab5 mod_php-4.3.0-r2.ebuild 8634
+MD5 c7aed18cbd3128eec686145cf7527728 ChangeLog 14984
+MD5 c585d6d5154fe64839f25db957301433 mod_php-4.3.1-r1.ebuild 9135
MD5 cceddd5c262e0ffef31d45b7da269851 files/mod_php.conf 148
MD5 6cf293d9a0faa0e7e5d86d9fd2d47131 files/70_mod_php.conf 329
MD5 316366d60770de4c45957483cde50fe8 files/digest-mod_php-4.3.1 63
diff --git a/dev-php/mod_php/mod_php-4.3.1-r3.ebuild b/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
index fb1ce37d98db..b9656303d643 100644
--- a/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1-r3.ebuild,v 1.4 2003/04/24 17:54:46 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1-r3.ebuild,v 1.5 2003/05/13 09:46:07 robbat2 Exp $
inherit php eutils
@@ -28,17 +28,9 @@ src_compile() {
myconf="${myconf} --without-readline "
# optional support for apache2
- myconf="${myconf} --with-exec-dir=/usr/bin"
- if [ "`use apache2`" ] ; then
- myconf="${myconf} --with-apxs2=/usr/sbin/apxs2"
- else
- myconf="${myconf} --with-apxs=/usr/sbin/apxs"
- fi
-
- #turned off as of bug #17462
- #this is an extra item required with mcrypt (which is include in the eclass) when used with apache
- #use crypt && myconf="${myconf} --disable-posix-threads"
-
+ use apache2 \
+ && myconf="${myconf} --with-apxs2=/usr/sbin/apxs2" \
+ || myconf="${myconf} --with-apxs=/usr/sbin/apxs"
#php CGI stuff
#--enable-discard-path --enable-force-cgi-redirect