summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-27 12:19:04 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-27 12:19:04 +0000
commit597238895ad8c2a0528eb63ff0b10f74abdef74f (patch)
treec1f01323b2603d5a32052403f4b9eb5ba6bd2b4d /app-admin/watchdog
parentcreate /dev device (diff)
downloadhistorical-597238895ad8c2a0528eb63ff0b10f74abdef74f.tar.gz
historical-597238895ad8c2a0528eb63ff0b10f74abdef74f.tar.bz2
historical-597238895ad8c2a0528eb63ff0b10f74abdef74f.zip
errno fix
Diffstat (limited to 'app-admin/watchdog')
-rw-r--r--app-admin/watchdog/ChangeLog6
-rw-r--r--app-admin/watchdog/files/watchdog-5.2-alpha.diff12
-rw-r--r--app-admin/watchdog/watchdog-5.2.ebuild8
3 files changed, 23 insertions, 3 deletions
diff --git a/app-admin/watchdog/ChangeLog b/app-admin/watchdog/ChangeLog
index 0af2f8268359..cacbc5006699 100644
--- a/app-admin/watchdog/ChangeLog
+++ b/app-admin/watchdog/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for app-admin/watchdog
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/ChangeLog,v 1.4 2003/02/12 02:28:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/ChangeLog,v 1.5 2003/03/27 12:19:04 liquidx Exp $
*watchdog-5.2 (Mar 3, 2002)
+ 27 Mar 2003; Alastair Tse <liquidx@gentoo.org> watchdog-5.2.ebuild,
+ files/watchdog-5.2-alpha.diff:
+ added glibc-2.3.2 errno fix. thanks to pst@ican.at. fixes #18219.
+
29 Oct 2002; Nick Hadaway <raker@gentoo.org> watchdog-5.2.ebuild,
files/sundries.diff :
Added a diff to fix compiling problems. See bug #8567
diff --git a/app-admin/watchdog/files/watchdog-5.2-alpha.diff b/app-admin/watchdog/files/watchdog-5.2-alpha.diff
new file mode 100644
index 000000000000..1762e87329f9
--- /dev/null
+++ b/app-admin/watchdog/files/watchdog-5.2-alpha.diff
@@ -0,0 +1,12 @@
+--- watchdog-5.2/src/quotactl.c 1999-09-09 11:03:06.000000000 +0200
++++ watchdog-5.2-modified/src/quotactl.c 2003-03-26 14:51:41.000000000 +0100
+@@ -23,8 +23,8 @@
+ #include "config.h"
+ #endif
+
+-#if defined(__alpha__)
+ #include <errno.h>
++#if defined(__alpha__)
+ #include <sys/types.h>
+ #include <syscall.h>
+ #include <unistd.h>
diff --git a/app-admin/watchdog/watchdog-5.2.ebuild b/app-admin/watchdog/watchdog-5.2.ebuild
index df1d641bb2cb..f9089acf535b 100644
--- a/app-admin/watchdog/watchdog-5.2.ebuild
+++ b/app-admin/watchdog/watchdog-5.2.ebuild
@@ -1,7 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.12 2003/02/13 05:32:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.13 2003/03/27 12:19:04 liquidx Exp $
+inherit eutils
+
+IUSE=""
DESCRIPTION="A software watchdog."
HOMEPAGE="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/"
SRC_URI="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/${P}.tar.gz"
@@ -13,7 +16,8 @@ DEPEND="virtual/glibc"
src_unpack() {
unpack ${A} ; cd ${S}
- patch -p1 < ${FILESDIR}/sundries.diff || die "patch failed"
+ epatch ${FILESDIR}/sundries.diff || die "patch failed"
+ epatch ${FILESDIR}/${P}-alpha.diff || die "patch failed"
}
src_compile() {