summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-09-14 22:28:25 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-09-14 22:28:25 +0000
commita44baf91d28e97bc37aa63970059dd3aa7b47337 (patch)
tree3c42d0722db875917cb0de763bca9daaba9efb8a /app-admin/webmin
parentCorrected depend lines for forcing makemaker install - this will fix (diff)
downloadhistorical-a44baf91d28e97bc37aa63970059dd3aa7b47337.tar.gz
historical-a44baf91d28e97bc37aa63970059dd3aa7b47337.tar.bz2
historical-a44baf91d28e97bc37aa63970059dd3aa7b47337.zip
version bump
Diffstat (limited to 'app-admin/webmin')
-rw-r--r--app-admin/webmin/ChangeLog10
-rw-r--r--app-admin/webmin/files/digest-webmin-1.0001
-rw-r--r--app-admin/webmin/webmin-1.000.ebuild64
3 files changed, 74 insertions, 1 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
index 9267090b21cf..46cb7c447f6c 100644
--- a/app-admin/webmin/ChangeLog
+++ b/app-admin/webmin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/webmin
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.2 2002/08/13 21:24:58 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.3 2002/09/14 22:28:24 seemant Exp $
+
+*webmin-1.000 (14 Sep 2002)
+
+ 14 Sep 2002; Seemant Kulleen <seemant@gentoo.org> webmin-1.000.ebuild
+ files/digest-webmin-1.000 :
+
+ Upstream version bump. Thanks to: GertThiel@gmx.net (Gert Thiel) for the
+ ebuild submission in bug #7861.
*webmin-0.992 (09 Jul 2002)
diff --git a/app-admin/webmin/files/digest-webmin-1.000 b/app-admin/webmin/files/digest-webmin-1.000
new file mode 100644
index 000000000000..57e0a3bb1e06
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.000
@@ -0,0 +1 @@
+MD5 f9c22ab47a4a5fb2d96d1d79fe8207a2 webmin-1.000.tar.gz 5643949
diff --git a/app-admin/webmin/webmin-1.000.ebuild b/app-admin/webmin/webmin-1.000.ebuild
new file mode 100644
index 000000000000..de8e620354b2
--- /dev/null
+++ b/app-admin/webmin/webmin-1.000.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2002, Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.000.ebuild,v 1.1 2002/09/14 22:28:24 seemant Exp $
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+SRC_URI="http://www.webmin.com/download/${P}.tar.gz"
+HOMEPAGE="http://www.webmin.com/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="sys-devel/perl
+ ssl? ( dev-perl/Net-SSLeay )"
+
+RDEPEND=""
+
+src_install() {
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ mkdir -p ${D}/usr/libexec/webmin
+ mkdir -p ${D}/etc/init.d
+ mkdir -p ${D}/var
+ mkdir -p ${D}/etc/pam.d
+ cp -rp * ${D}/usr/libexec/webmin
+ cp webmin-gentoo-init ${D}/etc/init.d/webmin
+ cp webmin-pam ${D}/etc/pam.d/webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ exeinto /etc/webmin
+ doexe ${FILESDIR}/uninstall.sh
+
+}
+
+pkg_postinst() {
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ stopstatus=$?
+ cd /usr/libexec/webmin
+ config_dir=/etc/webmin
+ var_dir=/var/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/webmin/maketemp.pl
+ ./setup.sh >/tmp/.webmin/webmin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/webmin start
+ fi
+}