summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-07-24 13:00:37 +0000
committerNed Ludd <solar@gentoo.org>2004-07-24 13:00:37 +0000
commitba8809e856b0ca726e6ad645fa448bc505cee1cc (patch)
tree83e344ab7664663f9e9abcf4cea72fe22688d079 /app-admin
parentinitial ebuild, closes #42978 (diff)
downloadhistorical-ba8809e856b0ca726e6ad645fa448bc505cee1cc.tar.gz
historical-ba8809e856b0ca726e6ad645fa448bc505cee1cc.tar.bz2
historical-ba8809e856b0ca726e6ad645fa448bc505cee1cc.zip
add support for rkhunter automation thanks to Aaron Walker bug 57829
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/rkhunter/ChangeLog5
-rw-r--r--app-admin/rkhunter/Manifest5
-rw-r--r--app-admin/rkhunter/files/rkhunter.cron41
-rw-r--r--app-admin/rkhunter/rkhunter-1.1.3.ebuild11
4 files changed, 55 insertions, 7 deletions
diff --git a/app-admin/rkhunter/ChangeLog b/app-admin/rkhunter/ChangeLog
index afdb1342a743..f109f6b0485b 100644
--- a/app-admin/rkhunter/ChangeLog
+++ b/app-admin/rkhunter/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for app-admin/rkhunter
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/rkhunter/ChangeLog,v 1.10 2004/07/23 23:36:52 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/rkhunter/ChangeLog,v 1.11 2004/07/24 13:00:37 solar Exp $
24 Jul 2004; Bryan Østergaard <kloeri@gentoo.org> rkhunter-1.1.2.ebuild:
Stable on alpha.
+ 24 Jul 2004; <solar@gentoo.org> rkhunter-1.1.3.ebuild, files/rkhunter.cron:
+ add support for rkhunter automation thanks to Aaron Walker bug 57829
+
*rkhunter-1.1.3 (23 Jul 2004)
23 Jul 2004; <solar@gentoo.org> rkhunter-1.0.9.ebuild,
diff --git a/app-admin/rkhunter/Manifest b/app-admin/rkhunter/Manifest
index 23332801912c..b134eea27cd9 100644
--- a/app-admin/rkhunter/Manifest
+++ b/app-admin/rkhunter/Manifest
@@ -1,6 +1,7 @@
MD5 7bd0e1a3e095605bb8980dd84077ae81 rkhunter-1.1.2.ebuild 1300
-MD5 9378b6edfd320550bc3f9f3a2fc39556 ChangeLog 1325
+MD5 9fcddb1580d8cc7887be8c4d943bf6f3 ChangeLog 1474
MD5 e412a91eab0edc866384121b20ab8793 metadata.xml 230
-MD5 f70043d2cc693a8aef0e76047eca4fa7 rkhunter-1.1.3.ebuild 1301
+MD5 902bb009e5a43fac6d1887c2eb2d7780 rkhunter-1.1.3.ebuild 1310
+MD5 1043a5f848ea01acabaef6863447594d files/rkhunter.cron 885
MD5 5de4d37c7da782413685c1d8b1e4b32d files/digest-rkhunter-1.1.2 65
MD5 ece1f3704a39ec6ba63b88e6b9ee13ca files/digest-rkhunter-1.1.3 65
diff --git a/app-admin/rkhunter/files/rkhunter.cron b/app-admin/rkhunter/files/rkhunter.cron
new file mode 100644
index 000000000000..aeb45eec4152
--- /dev/null
+++ b/app-admin/rkhunter/files/rkhunter.cron
@@ -0,0 +1,41 @@
+#!/bin/sh
+
+### Begin Configuration ###
+
+# set this to 'yes' to enable
+ENABLE=no
+
+RKHUNTER_EXEC="/usr/bin/rkhunter"
+RKHUNTER_OPTS="--checkall --cronjob --skip-keypress"
+
+# set to 'yes' if you wish the output to be mailed to you
+SEND_EMAIL=no
+
+# NOTE: the rest of these options are only relevant
+# if you set SEND_EMAIL to 'yes'
+
+EMAIL_SUBJECT="${HOSTNAME}: rkhunter output"
+EMAIL_RECIPIENT=root
+EMAIL_CMD="| mail -s \"${EMAIL_SUBJECT}\" ${EMAIL_RECIPIENT}"
+
+# set to 1 to recieve only warnings & errors
+# set to 2 to recieve ALL rkhunter output
+EMAIL_VERBOSITY=1
+
+### End Configuration ###
+
+if [ "${ENABLE}" = "yes" ]; then
+ CMD="${RKHUNTER_EXEC} ${RKHUNTER_OPTS}"
+
+ if [ "${SEND_EMAIL}" = "yes" ]; then
+ if [ "${EMAIL_VERBOSITY}" -eq 1 ]; then
+ CMD="${CMD} --quiet ${EMAIL_CMD}"
+ else
+ CMD="${CMD} ${EMAIL_CMD}"
+ fi
+ else
+ CMD="${CMD} &>/dev/null"
+ fi
+
+ eval exec "${CMD}"
+fi
diff --git a/app-admin/rkhunter/rkhunter-1.1.3.ebuild b/app-admin/rkhunter/rkhunter-1.1.3.ebuild
index 308668110d53..942d369029b0 100644
--- a/app-admin/rkhunter/rkhunter-1.1.3.ebuild
+++ b/app-admin/rkhunter/rkhunter-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/rkhunter/rkhunter-1.1.3.ebuild,v 1.1 2004/07/23 17:06:20 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/rkhunter/rkhunter-1.1.3.ebuild,v 1.2 2004/07/24 13:00:37 solar Exp $
DESCRIPTION="Rootkit Hunter scans for known and unknown rootkits, backdoors, and sniffers."
HOMEPAGE="http://www.rootkit.nl/"
@@ -30,13 +30,16 @@ src_install() {
exeinto /usr/bin
doexe rkhunter
dodoc CHANGELOG LICENSE README WISHLIST
+
+ exeinto /etc/cron.daily
+ newexe ${FILESDIR}/rkhunter.cron rkhunter
}
pkg_postinst() {
echo
- einfo "Add the following to /etc/crontab to run un Rootkit Hunter as a cronjob:"
- einfo "30 5 * * * root /usr/bin/rkhunter -c --cronjob <more options>"
- einfo "Rootkit Hunter will now run on a daily basis at 5:30 (AM)"
+ einfo "A cron script has been installed to /etc/cron.daily/rkhunter."
+ einfo "To enable it, edit /etc/cron.daily/rkhunter and follow the"
+ einfo "directions."
echo
}