summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-04-16 12:26:03 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-04-16 12:26:03 +0000
commit0723e590802b6a5469d62382ec7adc1d9ab1b018 (patch)
tree5c710908d04f91f13dbf474e887e7e9d4c0ebb82 /app-arch/flexbackup
parentInitial ebuild by myself. (diff)
downloadhistorical-0723e590802b6a5469d62382ec7adc1d9ab1b018.tar.gz
historical-0723e590802b6a5469d62382ec7adc1d9ab1b018.tar.bz2
historical-0723e590802b6a5469d62382ec7adc1d9ab1b018.zip
Initial ebuild by myself.
Diffstat (limited to 'app-arch/flexbackup')
-rw-r--r--app-arch/flexbackup/Manifest5
-rw-r--r--app-arch/flexbackup/files/Makefile-gentoo.diff13
-rw-r--r--app-arch/flexbackup/files/digest-flexbackup-1.0.31
-rw-r--r--app-arch/flexbackup/files/digest-flexbackup-1.1.61
-rw-r--r--app-arch/flexbackup/flexbackup-1.0.3.ebuild50
-rw-r--r--app-arch/flexbackup/flexbackup-1.1.6.ebuild50
6 files changed, 118 insertions, 2 deletions
diff --git a/app-arch/flexbackup/Manifest b/app-arch/flexbackup/Manifest
index bba2a2f74efb..1be0a85d11e8 100644
--- a/app-arch/flexbackup/Manifest
+++ b/app-arch/flexbackup/Manifest
@@ -1,5 +1,6 @@
-MD5 23f30e68af6c0e81c4a7e1ea1a507dd7 flexbackup-1.0.3.ebuild 1179
-MD5 23f30e68af6c0e81c4a7e1ea1a507dd7 flexbackup-1.1.6.ebuild 1179
+MD5 0fea23b8012bfb938510fb015e81b591 flexbackup-1.0.3.ebuild 1287
+MD5 4ddc6ac0d5f66e4976037615ae25d6db flexbackup-1.1.6.ebuild 1287
+MD5 290f16d86740515a5ff26b0faee919d7 ChangeLog 481
MD5 9c399ba0be754b014304d901ba40199b files/digest-flexbackup-1.0.3 67
MD5 2cb23054a60bcebe909357d8528ae390 files/digest-flexbackup-1.1.6 67
MD5 14858ea6950835f29fa80e2921940b3b files/Makefile-gentoo.diff 397
diff --git a/app-arch/flexbackup/files/Makefile-gentoo.diff b/app-arch/flexbackup/files/Makefile-gentoo.diff
new file mode 100644
index 000000000000..b4aac133e376
--- /dev/null
+++ b/app-arch/flexbackup/files/Makefile-gentoo.diff
@@ -0,0 +1,13 @@
+--- Makefile.org 2003-04-16 12:47:58.000000000 +0000
++++ Makefile 2003-04-16 12:48:27.000000000 +0000
+@@ -18,8 +18,8 @@
+ all: fb.install
+
+ install: all
+- install -m 0644 flexbackup.conf $(CONFFILE)
+- install -m 0755 fb.install $(BINPATH)/flexbackup
++ install -m 0644 flexbackup.conf ${D}$(CONFFILE)
++ install -m 0755 fb.install ${D}$(BINPATH)/flexbackup
+
+ fb.install:
+ cp flexbackup fb.install
diff --git a/app-arch/flexbackup/files/digest-flexbackup-1.0.3 b/app-arch/flexbackup/files/digest-flexbackup-1.0.3
new file mode 100644
index 000000000000..e2383a32dfeb
--- /dev/null
+++ b/app-arch/flexbackup/files/digest-flexbackup-1.0.3
@@ -0,0 +1 @@
+MD5 974bb2b7bde791c2aca87a1bf272010b flexbackup-1.0.3.tar.gz 59738
diff --git a/app-arch/flexbackup/files/digest-flexbackup-1.1.6 b/app-arch/flexbackup/files/digest-flexbackup-1.1.6
new file mode 100644
index 000000000000..b3e389cb4761
--- /dev/null
+++ b/app-arch/flexbackup/files/digest-flexbackup-1.1.6
@@ -0,0 +1 @@
+MD5 13bd9ecaff30b8ed1149017d1581335a flexbackup-1.1.6.tar.gz 61198
diff --git a/app-arch/flexbackup/flexbackup-1.0.3.ebuild b/app-arch/flexbackup/flexbackup-1.0.3.ebuild
new file mode 100644
index 000000000000..1ee148c5b7f0
--- /dev/null
+++ b/app-arch/flexbackup/flexbackup-1.0.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License
+# $Header: /var/cvsroot/gentoo-x86/app-arch/flexbackup/flexbackup-1.0.3.ebuild,v 1.1 2003/04/16 12:25:49 mholzer Exp $
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Flexible backup script using perl"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://flexbackup.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="virtual/glibc"
+RDEPEND="app-arch/afio
+ app-arch/mt-st
+ app-arch/dump
+ sys-apps/findutils
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ epatch ${FILESDIR}/Makefile-gentoo.diff
+ # emake (previously known as pmake) is a script that calls the
+ # standard GNU make with parallel building options for speedier
+ # builds (especially on SMP systems). Try emake first. It might
+ # not work for some packages, in which case you'll have to resort
+ # to normal "make".
+ emake || die
+ #make || die
+}
+
+src_install() {
+ dodir /etc
+ dodir /usr/bin
+ make DESTDIR=${D} install || die
+ dodoc CHANGES COPYING CREDITS FAQ INSTALL README TODO
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "now edit your /etc/${PN}.conf"
+ einfo "if you are using devfs, the tape device"
+ einfo "should be set to /dev/tapes/tape0/mtn"
+ einfo ""
+}
diff --git a/app-arch/flexbackup/flexbackup-1.1.6.ebuild b/app-arch/flexbackup/flexbackup-1.1.6.ebuild
new file mode 100644
index 000000000000..434022b1ffd1
--- /dev/null
+++ b/app-arch/flexbackup/flexbackup-1.1.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License
+# $Header: /var/cvsroot/gentoo-x86/app-arch/flexbackup/flexbackup-1.1.6.ebuild,v 1.1 2003/04/16 12:25:49 mholzer Exp $
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Flexible backup script using perl"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://flexbackup.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="virtual/glibc"
+RDEPEND="app-arch/afio
+ app-arch/mt-st
+ app-arch/dump
+ sys-apps/findutils
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ epatch ${FILESDIR}/Makefile-gentoo.diff
+ # emake (previously known as pmake) is a script that calls the
+ # standard GNU make with parallel building options for speedier
+ # builds (especially on SMP systems). Try emake first. It might
+ # not work for some packages, in which case you'll have to resort
+ # to normal "make".
+ emake || die
+ #make || die
+}
+
+src_install() {
+ dodir /etc
+ dodir /usr/bin
+ make DESTDIR=${D} install || die
+ dodoc CHANGES COPYING CREDITS FAQ INSTALL README TODO
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "now edit your /etc/${PN}.conf"
+ einfo "if you are using devfs, the tape device"
+ einfo "should be set to /dev/tapes/tape0/mtn"
+ einfo ""
+}