summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-08 22:04:28 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-08 22:04:28 +0000
commitc7e06d1604225fe1a9cdef16b9c9e4f7bd6423af (patch)
tree6312ad2706581dba81d693dea6352e65d8f7965f /app-arch/flexbackup
parentVersion bumped. (diff)
downloadhistorical-c7e06d1604225fe1a9cdef16b9c9e4f7bd6423af.tar.gz
historical-c7e06d1604225fe1a9cdef16b9c9e4f7bd6423af.tar.bz2
historical-c7e06d1604225fe1a9cdef16b9c9e4f7bd6423af.zip
Version bumped.
Diffstat (limited to 'app-arch/flexbackup')
-rw-r--r--app-arch/flexbackup/Manifest4
-rw-r--r--app-arch/flexbackup/files/digest-flexbackup-1.2.01
-rw-r--r--app-arch/flexbackup/flexbackup-1.2.0.ebuild45
3 files changed, 48 insertions, 2 deletions
diff --git a/app-arch/flexbackup/Manifest b/app-arch/flexbackup/Manifest
index 2133bf22bf61..e220e6c8d333 100644
--- a/app-arch/flexbackup/Manifest
+++ b/app-arch/flexbackup/Manifest
@@ -1,7 +1,7 @@
-MD5 11119d642906f7fe3687f9a21d3f930d ChangeLog 989
+MD5 e72938b9c035b4d78b251366cb6aef00 ChangeLog 1116
MD5 c71d87c579eda2ae84fe2371c299e0f0 flexbackup-1.0.5.ebuild 1004
MD5 382e991164f4b4a0b6a1f4c904051472 flexbackup-1.1.8.ebuild 1004
-MD5 c71d87c579eda2ae84fe2371c299e0f0 flexbackup-1.2.0.ebuild 1004
+MD5 58cacb8fab8575011f407a866b612392 flexbackup-1.2.0.ebuild 1004
MD5 14858ea6950835f29fa80e2921940b3b files/Makefile-gentoo.diff 397
MD5 fe93b34927598c85a800fc5b8f6e251c files/digest-flexbackup-1.0.5 67
MD5 09595f2b63f871553a52739343e55de9 files/digest-flexbackup-1.1.8 67
diff --git a/app-arch/flexbackup/files/digest-flexbackup-1.2.0 b/app-arch/flexbackup/files/digest-flexbackup-1.2.0
new file mode 100644
index 000000000000..da5bb7944a12
--- /dev/null
+++ b/app-arch/flexbackup/files/digest-flexbackup-1.2.0
@@ -0,0 +1 @@
+MD5 a5e57e7070ad3da1b5a9e0aed2aeda83 flexbackup-1.2.0.tar.gz 73170
diff --git a/app-arch/flexbackup/flexbackup-1.2.0.ebuild b/app-arch/flexbackup/flexbackup-1.2.0.ebuild
new file mode 100644
index 000000000000..ea84be663a2b
--- /dev/null
+++ b/app-arch/flexbackup/flexbackup-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License
+# $Header: /var/cvsroot/gentoo-x86/app-arch/flexbackup/flexbackup-1.2.0.ebuild,v 1.1 2003/07/08 22:04:18 mholzer Exp $
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Flexible backup script using perl"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://flexbackup.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="virtual/glibc"
+RDEPEND="app-arch/afio
+ app-arch/mt-st
+ app-arch/dump
+ sys-apps/findutils
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ epatch ${FILESDIR}/Makefile-gentoo.diff
+ emake || die
+}
+
+src_install() {
+ dodir /etc
+ dodir /usr/bin
+ make DESTDIR=${D} install || die
+ dodoc CHANGES COPYING CREDITS INSTALL README TODO
+ dohtml faq.html
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "now edit your /etc/${PN}.conf"
+ einfo "if you are using devfs, the tape device"
+ einfo "should be set to /dev/tapes/tape0/mtn"
+ einfo ""
+}