summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-26 00:18:03 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-26 00:18:03 +0000
commit5cbaea67ed0747297755b6ac598514b53382de98 (patch)
treee5800777e5feafb662354cdceb8b9d3a9c0bf35c /app-arch
parentFix mistake in the startup script. (diff)
downloadhistorical-5cbaea67ed0747297755b6ac598514b53382de98.tar.gz
historical-5cbaea67ed0747297755b6ac598514b53382de98.tar.bz2
historical-5cbaea67ed0747297755b6ac598514b53382de98.zip
old
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip2/Manifest3
-rw-r--r--app-arch/bzip2/bzip2-1.0.3-r2.ebuild77
-rw-r--r--app-arch/bzip2/bzip2-1.0.3-r3.ebuild79
-rw-r--r--app-arch/bzip2/files/digest-bzip2-1.0.3-r21
-rw-r--r--app-arch/bzip2/files/digest-bzip2-1.0.3-r31
5 files changed, 0 insertions, 161 deletions
diff --git a/app-arch/bzip2/Manifest b/app-arch/bzip2/Manifest
index 4241ad99ee32..b236e3356762 100644
--- a/app-arch/bzip2/Manifest
+++ b/app-arch/bzip2/Manifest
@@ -1,9 +1,7 @@
MD5 93e74da18f5e6544e5314e2b8f0381cc ChangeLog 6445
MD5 c7ae74d80c4fd172fc83b5f41de30ea4 bzip2-1.0.2-r5.ebuild 2203
-MD5 cc2e9e810cc6b1cf37fd567e1699df91 bzip2-1.0.3-r3.ebuild 2295
MD5 2bced66d4d3c68070477627caa87f172 bzip2-1.0.3.ebuild 2021
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 328d582d46b23f945a883dd946d975a2 bzip2-1.0.3-r2.ebuild 2213
MD5 8ba714af581ba34afae6c1b219f471cc bzip2-1.0.3-r4.ebuild 2300
MD5 9c63b399f71b03f2a58b061c1e038d0c files/bzip2-1.0.2-saneso.patch 457
MD5 f413035bf75710d87670f302692e1233 files/digest-bzip2-1.0.3 63
@@ -14,5 +12,4 @@ MD5 382f154f0ba01de10aff6207652d6799 files/digest-bzip2-1.0.2-r5 63
MD5 be84e51b1bd56731f5d7762980e3ad47 files/bzip2-1.0.3-makefile-CFLAGS.patch 489
MD5 d1cf85cb43e35c9ecba9954295318ab8 files/bzip2-1.0.3-saneso.patch 323
MD5 a0833247f0c02ccb65cceb33ea521457 files/bzip2-1.0.2-chmod.patch 2780
-MD5 f413035bf75710d87670f302692e1233 files/digest-bzip2-1.0.3-r2 63
MD5 f413035bf75710d87670f302692e1233 files/digest-bzip2-1.0.3-r4 63
diff --git a/app-arch/bzip2/bzip2-1.0.3-r2.ebuild b/app-arch/bzip2/bzip2-1.0.3-r2.ebuild
deleted file mode 100644
index 17091542482a..000000000000
--- a/app-arch/bzip2/bzip2-1.0.3-r2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.3-r2.ebuild,v 1.1 2005/05/14 17:36:14 vapier Exp $
-
-inherit multilib toolchain-funcs flag-o-matic
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="http://www.bzip.org/"
-SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="build static"
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.0.2-NULL-ptr-check.patch
- epatch "${FILESDIR}"/${P}-makefile-CFLAGS.patch
- epatch "${FILESDIR}"/${P}-saneso.patch
- epatch "${FILESDIR}"/${PN}-1.0.2-progress.patch
- sed -i -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' Makefile || die "sed manpath"
-
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:ln $(PREFIX)/bin/:ln -s :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die "sed links"
-
- # bzip2 will to run itself after it has built itself which we
- # can't do if we are cross compiling. -solar
- if [[ -x /bin/bzip2 ]] && tc-is-cross-compiler ; then
- sed -i -e 's:./bzip2 -:bzip2 -:g' Makefile || die "sed cross-compile"
- fi
-}
-
-src_compile() {
- local makeopts="
- CC=$(tc-getCC)
- AR=$(tc-getAR)
- RANLIB=$(tc-getRANLIB)
- "
- if ! use build ; then
- emake ${makeopts} -f Makefile-libbz2_so all || die "Make failed libbz2"
- fi
- use static && append-flags -static
- emake ${makeopts} all || die "Make failed"
-}
-
-src_install() {
- if ! use build ; then
- make PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
-
- # move bzip2 binaries to / and use the shared libbz2.so
- mv "${D}"/usr/bin "${D}"/
- into /
- if ! use static ; then
- newbin bzip2-shared bzip2 || die "dobin shared"
- fi
- dolib.so "${S}"/libbz2.so.${PV} || die "dolib shared"
- for v in ${PV%%.*} ${PV%.*} ; do
- dosym libbz2.so.${PV} /$(get_libdir)/libbz2.so.${v}
- done
-
- dodoc README* CHANGES Y2K_INFO bzip2.txt manual.*
- else
- into /
- dobin bzip2 || die "dobin bzip2"
- fi
-
- dosym bzip2 /bin/bzcat
- dosym bzip2 /bin/bunzip2
-}
diff --git a/app-arch/bzip2/bzip2-1.0.3-r3.ebuild b/app-arch/bzip2/bzip2-1.0.3-r3.ebuild
deleted file mode 100644
index 82406e946ca8..000000000000
--- a/app-arch/bzip2/bzip2-1.0.3-r3.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.3-r3.ebuild,v 1.2 2005/05/23 22:29:50 vapier Exp $
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="http://www.bzip.org/"
-SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="build static"
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.0.2-NULL-ptr-check.patch
- epatch "${FILESDIR}"/${P}-makefile-CFLAGS.patch
- epatch "${FILESDIR}"/${P}-saneso.patch
- epatch "${FILESDIR}"/${PN}-1.0.2-progress.patch
- epatch "${FILESDIR}"/${PN}-1.0.2-chmod.patch
- sed -i -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' Makefile || die "sed manpath"
-
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:ln $(PREFIX)/bin/:ln -s :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die "sed links"
-
- # bzip2 will to run itself after it has built itself which we
- # can't do if we are cross compiling. -solar
- if [[ -x /bin/bzip2 ]] && tc-is-cross-compiler ; then
- sed -i -e 's:./bzip2 -:bzip2 -:g' Makefile || die "sed cross-compile"
- fi
-}
-
-src_compile() {
- local makeopts="
- CC=$(tc-getCC)
- AR=$(tc-getAR)
- RANLIB=$(tc-getRANLIB)
- "
- if ! use build ; then
- emake ${makeopts} -f Makefile-libbz2_so all || die "Make failed libbz2"
- fi
- use static && append-flags -static
- emake ${makeopts} all || die "Make failed"
-}
-
-src_install() {
- if ! use build ; then
- make PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
-
- # move bzip2 binaries to / and use the shared libbz2.so
- mv "${D}"/usr/bin "${D}"/
- into /
- if ! use static ; then
- newbin bzip2-shared bzip2 || die "dobin shared"
- fi
- dolib.so "${S}"/libbz2.so.${PV} || die "dolib shared"
- for v in ${PV%%.*} ${PV%.*} ; do
- dosym libbz2.so.${PV} /$(get_libdir)/libbz2.so.${v}
- done
- gen_usr_ldscript libbz2.so
-
- dodoc README* CHANGES Y2K_INFO bzip2.txt manual.*
- else
- into /
- dobin bzip2 || die "dobin bzip2"
- fi
-
- dosym bzip2 /bin/bzcat
- dosym bzip2 /bin/bunzip2
-}
diff --git a/app-arch/bzip2/files/digest-bzip2-1.0.3-r2 b/app-arch/bzip2/files/digest-bzip2-1.0.3-r2
deleted file mode 100644
index 24bf9c7e285a..000000000000
--- a/app-arch/bzip2/files/digest-bzip2-1.0.3-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8a716bebecb6e647d2e8a29ea5d8447f bzip2-1.0.3.tar.gz 669075
diff --git a/app-arch/bzip2/files/digest-bzip2-1.0.3-r3 b/app-arch/bzip2/files/digest-bzip2-1.0.3-r3
deleted file mode 100644
index 24bf9c7e285a..000000000000
--- a/app-arch/bzip2/files/digest-bzip2-1.0.3-r3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8a716bebecb6e647d2e8a29ea5d8447f bzip2-1.0.3.tar.gz 669075