summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2013-01-20 06:16:12 +0000
committerRyan Hill <rhill@gentoo.org>2013-01-20 06:16:12 +0000
commit8ca20abc737d7ed4b637c21a257414143fa50528 (patch)
tree7b8972f4b9f167c2cbfc6b8f90d690a779b91f9a /app-doc/abs-guide/abs-guide-6.6.ebuild
parentDev channel bump. (diff)
downloadhistorical-8ca20abc737d7ed4b637c21a257414143fa50528.tar.gz
historical-8ca20abc737d7ed4b637c21a257414143fa50528.tar.bz2
historical-8ca20abc737d7ed4b637c21a257414143fa50528.zip
Version bump. Remove old.
Package-Manager: portage-2.2.0_alpha157/cvs/Linux x86_64 Manifest-Sign-Key: 0x957A8463
Diffstat (limited to 'app-doc/abs-guide/abs-guide-6.6.ebuild')
-rw-r--r--app-doc/abs-guide/abs-guide-6.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-doc/abs-guide/abs-guide-6.6.ebuild b/app-doc/abs-guide/abs-guide-6.6.ebuild
new file mode 100644
index 000000000000..56cf8570ccc7
--- /dev/null
+++ b/app-doc/abs-guide/abs-guide-6.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/abs-guide/abs-guide-6.6.ebuild,v 1.1 2013/01/20 06:16:05 dirtyepic Exp $
+
+EAPI="4"
+
+DESCRIPTION="An advanced reference and a tutorial on bash shell scripting"
+HOMEPAGE="http://www.tldp.org/LDP/abs/html"
+
+# Upstream likes to update the tarballs without changing the names.
+# - http://bash.deta.in/abs-guide-${PV}.tar.bz2
+# - http://bash.deta.in/abs-guide.pdf <- remember to rename with ${PV}
+SRC_URI="http://dev.gentoo.org/~dirtyepic/dist/${P}.tar.bz2
+ pdf? ( http://dev.gentoo.org/~dirtyepic/dist/${P}.pdf )"
+
+LICENSE="OPL"
+IUSE="pdf"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/abs"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use pdf && cp "${DISTDIR}"/${P}.pdf "${S}"
+}
+
+src_install() {
+ dodoc -r *
+ docompress -x /usr/share/doc/${PF}
+}